Jump to content
General Bug Report Guidelines - Please Read ×

Everest Oberon Helmet Exterminate Mission Not Working


TheDoctor506
 Share

Recommended Posts

There was recently an alert for an Oberon helmet on Everest, Earth. The mission was an extermination, but no enemies seemed to be spawning. I played three games in a squad, when I entered, it immediately gave the waypoint to extraction and showed no enemies, only a couple began to spawn at the very end and then stopped spawning entirely. We tried having the entire squad standing on extraction, but nothing happened, then we also tried to get some more enemies to spawn to complete the objective, but the enemies stopped spawning. We ended up with about 30/50 kills on the best run. I then did it in solo where the same issue occurred except this time the Lotus told me to get to extraction and upon reaching extraction I instantly completed the mission without actually doing anything.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...