Jump to content
General Bug Report Guidelines - Please Read ×

Void fissures reward bug


xXZekken1Xx
 Share

Recommended Posts

I ran a neo fissure (interception - europa maybe) yesterday and selected the nova prime blueprint as reward but it didn't appear in my inventory. Also, i just run a meso fissure (helene - saturn) today and the same thing happened after selecting zephyr prime blueprint as reward.

Edited by xXZekken1Xx
Link to comment
Share on other sites

  • 2 weeks later...

I just ran a Lith Defense and on the third reward, I tried to pick the Ballistica Prime Blueprint (gold reward) and it wouldn't let me.

It just kept my Nami Skyla Prime Handle highlighted no matter what I clicked on.

Was yours actually highlighting and just not giving it to you, or were you not even able to click on it?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...