Jump to content
Dante Unbound: Known Issues ×
Dante Unbound: Share Bug Reports and Feedback Here! ×

Borderless fullscreen at 4k native res keeps capping my FPS to 55-56 until a reboot


Malurth
 Share

Recommended Posts

(First off, I know running 4k native res is very demanding. I'm not a dummy.)

So I got a new 4k screen (up from 1080p) and went to test how warframe would run on it. Turns out pretty well, as long as I turn a couple other settings down (most notably the internal render res AKA Resolution Scale).

...however, at some point, the game decides to put my framerate cap at 55-56 FPS, and the only thing that will solve it is rebooting my computer. (Yes, VSYNC is off and the framerate is uncapped). This is rather infuriating, since dropping below 60 makes for a super choppy experience and I can't stand it. If I use the 'scaled' option instead of native, I have zero performance issues of course, but then the game looks like ass (I'm assuming it's upscaling from 1080p but the upscaling makes it look significantly worse than native 1080p).

Unfortunately I now have to choose between a severe blurriness or a major performance issue, which is no bueno. Until now warframe has been super stable for me so this is quite saddening :<

edit: this is only while it's focused, too. when I unfocus the window my fps shoots up to 200.

edit 2: seems to be related to https://forums.warframe.com/topic/976491-borderless-fullscreen-framerate-drop-on-focus-gain/, which appears to be still unresolved. exclusive fullscreen does fix it, but goddamn I hate exclusive fullscreen.

Edited by Malurth
more info
Link to comment
Share on other sites

Which windows version you using?

On windows 7, try to turn off windows Aero.
On windows 10 Warframe, try in-game options, Display, scroll down, optimized flip model on, borderless, then restart game. Does this fix your problem of FPS drops?

Link to comment
Share on other sites

Windows 10.

I had optimized flip model on already...adopting your suggestion I toggled it back off. This probably actually fixed the issue, before its behavior was capped to 60 -> later 55/56, but now it's just running uncapped and I'm in the hundreds. Played a smidgen to test it, seems fine.

Guess I should have taken the 'experimental' tag on that option more seriously. Thanks for your help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...