Jump to content

After completing The Sacrifice and using Excalibur Umbra for a few days, the quest has been rolled back to unplayed and the equipment is missing.


PolyValence

Recommended Posts

After completing The Sacrifice and using Excalibur Umbra for a few days, the quest has been rolled back to unplayed and both Excalibur Umbra and Skiajati are missing from my arsenal.

The umbra mods are still in my inventory and both the Umbra and the sword show up in my profile as having been leveled up to max.

I did PUG missions after completing The Sacrifice, then picked up The Silver Grove quest, but did not start it. I can't think of anything else that might have triggered the bug.

Yes, I posted a support ticket for it, but started this thread so there is a searchable topic for other people as I did not find anything close to this problem online.

Link to comment
Share on other sites

This was the lazy response I got:

[DE]LianeToday at 02:45

Hi PolyValence,

Thank you for cotacting us. Upon checking your account it seems that you have yet to finish The Sacrifice quest.

Please note that crafting Excalibur Umbra will not fully unlock the Warframe. It will, however, become fully usable once you have completed the quest.

For more information please refer to the articles below.
https://warframe.fandom.com/wiki/Excalibur/Umbra
https://warframe.fandom.com/wiki/The_Sacrifice

Rest assured that your quest was not rolled back or reset.

Hope this helped. Feel free to re-open this ticket if you have any other questions regarding this matter.

Enjoy Warframe!


10/20/2020 I'm going to post the reopened ticket in public view as it seems like the only way I can motivate you to do the actual research.

Assigned to: [DE]Liane
Ticket #2330103
 

You didn't even research this beyond looking at my list of quests.

I will spell it out for you:

1. I finished the quest.

2. I crafted the Excalibur Umbra.

3. Look at my profile and you will see that the Umbra and the sword that came with it were leveled to MAX. I wouldn't have the Umbra mods, nor have been able to level the frame and sword to MAX if I had not finished the quest and been actively using both.

4. There is no point in me doing the quest AGAIN if I have no assurance the same bug will not happen again.

5. Please escalate this to someone who will do the research instead of taking a cursory look before snapping off a reply, then marking the ticket as 'solved'. You researched nothing. You solved nothing.

I'm infuriated by your dismissive stance that I am lying.


 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...