Jump to content
General Bug Report Guidelines - Please Read ×

Kubrow: Unable To Equip The Kubrow After Stasis


Recommended Posts

Kubrow/Inventory Bug:


After recovering my Kubrow from stasis, I could not equip her. I had just switched from my Raksa Kubrow to my Huras Kubrow and when I looked at the companions tab I saw that my Huras Kubrow was missing - although she was in the incubator module.


I've tried logging in again to fix it, but it doesn't work. It's really odd and inconvenient that only my sentinels show up under 'companions', even though I have acquired the collar and even though I was able to select my Raksa Kubrow before recovering my Huras Kubrow from stasis.

Link to comment
Share on other sites

You waited the three hours recovery time?


You must wait three hours for your Kubrow to recover from stasis.


There's a pointless 3 hour wait for recovery from stasis disabling you from equipping it.

I think I have, I'm not entirely sure though. When I tried to equip it right after stasis, I couldn't, but knowing of the waiting period, I tried it again after a few hours and still could not use my Kubrow (I'm pretty sure it was three hours, but I'll log back in right now to see if anything has changed).


EDIT: Now she's there, I waited for just under three hours *blush*. Sorry for wasting your time.

Edited by Cythphn
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...