Jump to content
General Bug Report Guidelines - Please Read ×

Weapons not switching during mission?


NovaXcaliber
 Share

Recommended Posts

So I was on an Infested sabotage mission. A juggernaut spawned and kept taking my squad down cuz we were in a tight corridor. I died once, my squadmates were all down, and I was left to fight it until my squad revived or died. I had my secondary equipped at the time and tried switching to my main. Nothing happened. I tried a few more times before mashing the switch weapons button, but it still didn't work. I tried hitting the juggernaut with my melee, but that didn't work either. So I had to spend the rest of the mission unable to use anything but my secondary.

Then it happened again in another mission. Anybody else have this problem before?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...