Jump to content


Photo

Ultimate Guide On How To Enable Nvidia's Physx


This topic has been archived. This means that you cannot reply to this topic.
29 replies to this topic

#1 ENBY

ENBY

    Gold Initiate

  • Hunter
  • 51 posts

Posted 09 April 2013 - 01:26 AM

Posted Image


Hey everyone, ENBY here.
I've seen a lot of people here having trouble with enabling PhysX, first my friends, then people on the forums in general seemed to have the same problem, so I thought about *trying* to help everyone the best I can.

Let's just get some stuff out of the way first.
- Make sure you have an Nvidia card with PhysX support.
- Make sure your GPU has *at least* 512MB of Vram.
Spoiler


Ok then, let's begin!


*** If you have the latest drivers skip to step 3. ***


Step 1. Make sure you have the latest drivers installed. If you don't know if you do or how to check it, chances are they're outdated. At the time that I'm writing this guide the latest stable release is 314.22 released on March 25th.
Just search for them here. ** Very Important ** If you're going to update to the latest driver, first do the following:
Access your control panel and go to "Uninstall program." If you have a program called NVIDIA PhysX System Software X.XX.XXXX then uninstall it first. Picture below for reference.



Posted Image




Ok, proceed to step 2 after the uninstall completes.

Step 2. Download the latest driver mentioned in the previous step and install it. ** Important ** When given the option, choose the "Custom/Advanced Install" instead of the default "Express Install". Then on the next window the important thing is that you check the option "Perform a clean install". Also, the 2 important components to have checked is Graphics Driver and PhysX System Software. Nvidia Update is up to you, if you want leave it on, it'll automatically update your drivers. *ALSO* If you have anything related to "HD Audio" uncheck it! 95% of all users won't benefit from that audio driver, and it may even break your computer. Many users reported having an unstable config or black screen at boot after installing the HD Audio driver. I don't know why Nvidia insists on bundling an audio driver with some packages...
Continue the installation. When done, reboot the computer as suggested and move on to step 3.

Step 3. After the reboot, access your Nvidia Control Panel. A new window pops up. Under your 3D Settings go to Set PhysX Configuration(1) then make sure your dedicated GPU(2) is chosen as the default, not the CPU nor the auto-select, then just hit apply.
Spoiler



Posted Image


Now move up to Manage 3D Settings(3) and on the Global Settings tab make sure you have your High-Performance NVIDIA Processor(4) selected then hit apply.

Posted Image


Next switch to your Program Settings (5) tab and click add (6). A new window pops up, just click Browse(7) then navigate to Warframe's install directory. Select the Warframe.exe and hit open/apply. (For the ones who have it installed through Steam the path looks something like "C:\Program Files (x86)\Steam\SteamApps\common\Warframe".)
Below it there's something pretty familiar to you by now, an option that says "Select the preferred graphics processor for this program", once more make sure that "High-Performance NVIDIA processor" is selected and click apply. Repeat the above steps for the files Warframe.x64.exe and Launcher.exe (which is inside the tools folder).

Posted Image


Posted Image


Ok, we're almost there!!!

Step 4. On your Warframe Launcher you'll see a little nut icon, click it and make sure all the boxes are checked. Then hit Play. (If your card only supports DirectX 10 then uncheck the DirectX11.)

Posted Image


Step 5. Success! Go to options menu and rape that Check box as you cry in happiness, you're now able to enable PhysX! (Hopefully......)


Posted Image


***
If after all this you're still unable to check that box, don't be mad or disappointed. Ask for help in this thread! I'm sure there's many people willing to help, like myself!
***

Through this I was able to help a lot of my friends and I hope it now helps all of you Tennos out there.
If you have anything to add please do! Comments and critics are always welcomed.

On a side note, if you happen to know how to enable PhysX for our AMD friends then post it in here! I'll be glad to move it to the first post.

I would like to end this guide with a thanks to the Devs, who really put a lot of their time just to make sure everything is perfect for us. The game looks incredibly good with all settings cranked up and I wasn't even aware of it until I enabled PhysX and stayed in awe just by shooting an explosive barrel...
The Devs, they're our heroes! Where we have fun, the devs have hard work to do instead, respect them and appreciate their job. (Kinda like the doorman in a disco... Or the gynecologist.. huh...)

Once more, if you see anything wrong please do tell! I've finished writing this guide at 7am so I may be a little tired.

Cheers!

Edited by ENBY, 09 April 2013 - 04:12 PM.


#2 NovaKiller

NovaKiller

    Gold Disciple

  • Grand Master
  • 436 posts

Posted 09 April 2013 - 01:33 AM

I have no idea if i can enable mine or not.
But if i have problems with that this guide seems like a good place to go.

Nice guide, can go through it fast or read it all.
+1

#3 TickleMyPickle

TickleMyPickle

    Initiate

  • Master
  • 3 posts

Posted 09 April 2013 - 11:11 AM

I couldn't get past step 3.4, there was no preffered graphics processor. Also do you have to have DirectX 11? I'm rocking a GT240 so I thought I would just throw that out there to see if you can help.

#4 VieuxPappy

VieuxPappy

    Disciple

  • Master
  • 275 posts

Posted 09 April 2013 - 12:44 PM

I have AMD.... I'm a sad Tenno :(

#5 ENBY

ENBY

    Gold Initiate

  • Hunter
  • 51 posts

Posted 09 April 2013 - 04:10 PM

I couldn't get past step 3.4, there was no preffered graphics processor. Also do you have to have DirectX 11? I'm rocking a GT240 so I thought I would just throw that out there to see if you can help.


Hey! Thanks for pointing that out, I completely forgot about that. When checking if your GPU supports PhysX you should also check if it is DX11 compatible or only DX10. Your GT240 only supports DX10, so in Step 4. you should uncheck Enable DirectX 11, of course. Then see if you can enable it! :)
About step 3.4, even tho you can't do that on the Global Settings tab, can you still select the Nvidia High-Performance Processor on the individual Program Settings tab? I've researched a little and found no one who couldn't see the nvidia one on the list.

I have AMD.... I'm a sad Tenno :(


Worry not, Tenno! I'm sure someone here will pop up soon with a tutorial on how to do it with AMD cards.

Edited by ENBY, 09 April 2013 - 04:11 PM.


#6 VieuxPappy

VieuxPappy

    Disciple

  • Master
  • 275 posts

Posted 09 April 2013 - 05:43 PM

Worry not, Tenno! I'm sure someone here will pop up soon with a tutorial on how to do it with AMD cards.


Lets hope! But are you sure its feasable with AMD cards? I always thought PhysX was only with NVIDIA? And also, what does enabling PhysX actually do in the game?

#7 Alcatraz968

Alcatraz968

    Gold Novice

  • Hunter
  • 187 posts

Posted 09 April 2013 - 09:12 PM

Lets hope! But are you sure its feasable with AMD cards? I always thought PhysX was only with NVIDIA? And also, what does enabling PhysX actually do in the game?



PhysX can be done on the CPU also. Intel or amd. PhysX can also be done on Nvidia cards, dedicated or in use rendering (will lower fps). For CPU rendering, get the software from nvidas site, or Google it.

Sorry for grammer/ errors. On tablet currently.

#8 ENBY

ENBY

    Gold Initiate

  • Hunter
  • 51 posts

Posted 09 April 2013 - 09:58 PM

Lets hope! But are you sure its feasable with AMD cards? I always thought PhysX was only with NVIDIA? And also, what does enabling PhysX actually do in the game?

Hi! I can't say for sure that it's feasible, but if you lurk around google you can find some people on forums explaining how to do it.

As for the PhysX does, check this recent trailer from nvidia's channel.


PhysX can be done on the CPU also. Intel or amd. PhysX can also be done on Nvidia cards, dedicated or in use rendering (will lower fps). For CPU rendering, get the software from nvidas site, or Google it.

Sorry for grammer/ errors. On tablet currently.


While that is technically true, enabling your CPU to be your main PhysX processor is very, very taxing on it. Of course this depends on your processor, but you get the idea. You can also set your integrated GPU to be your PhysX processor but it goes the same way as the CPUs.

Edited by ENBY, 09 April 2013 - 10:04 PM.


#9 Mayflower

Mayflower

    Gold Initiate

  • PC Member
  • 71 posts

Posted 14 April 2013 - 12:45 PM

The HD Audio in Nvidia drivers is because of HDMI supporting audio, so it can transmit audio from your computer via HDMI cable(s) to whatever device you've attached to them (such as a TV).



#10 blazerdrive09

blazerdrive09

    Initiate

  • PC Member
  • 1 posts

Posted 14 April 2013 - 09:34 PM

Oh Your guide is great if Physx doesn't work but it didn't work out for me but i figured out why Physx wasn't working.  I downloaded Warframe off the site but then I saw that it is in steam and then downloaded the steam one.  Apparently Physx doesnt work in steam properly and I didn't know that and was trying to get it fixed because it worked in my not steam one before i found the steam version.  Just putting it out there that the Physx button doesn't work in steam so you guys won't have to spend 4 hours trying to figure it out like i did :).



#11 Prash

Prash

    Initiate

  • PC Member
  • 1 posts

Posted 21 April 2013 - 06:38 AM

I have a nvidia gts 250

 

Hey! Thanks for pointing that out, I completely forgot about that. When checking if your GPU supports PhysX you should also check if it is DX11 compatible or only DX10. Your GT240 only supports DX10, so in Step 4. you should uncheck Enable DirectX 11, of course. Then see if you can enable it! :)
About step 3.4, even tho you can't do that on the Global Settings tab, can you still select the Nvidia High-Performance Processor on the individual Program Settings tab? I've researched a little and found no one who couldn't see the nvidia one on the list.



Worry not, Tenno! I'm sure someone here will pop up soon with a tutorial on how to do it with AMD cards.

 

 

I have the nvidia gts 250, supposedly to play with physX but can not find what deveria be in step 3.4. Any solution?



#12 Evan_

Evan_

    Disciple

  • PC Member
  • 256 posts

Posted 21 April 2013 - 07:08 AM

Just putting it out there that the Physx button doesn't work in steam so you guys won't have to spend 4 hours trying to figure it out like i did :).

 

Can someone confirm that? I find it unlikely, but well... I already have my 4 hours into enabling PhisX... and neither that, or other more detailed guides did help.



#13 223kazin

223kazin

    Novice

  • Master
  • 95 posts

Posted 21 April 2013 - 07:29 AM

Why would you enable it?. I'm always playing with a buddy of mine who plays a Nyx and I had to turn it off because of the green particle effects EVERYWHERE. I could not see a god damned thing. My only options were: A).Wait  B).Spray  C).Swing like a guy being attacked by bees.

 

Seriously, don't get bent out of shape over PhysX, it's better left off until the particle effects are toned down.



#14 Evan_

Evan_

    Disciple

  • PC Member
  • 256 posts

Posted 21 April 2013 - 07:58 AM

Why Mortal Kombat got that many sequels? I want the blood splatter effects. :-]



#15 warkid06

warkid06

    Initiate

  • PC Member
  • 12 posts

Posted 23 April 2013 - 04:25 AM

Why Mortal Kombat got that many sequels? I want the blood splatter effects. :-]

You mean you cant see blood effects on the walls and floors? 

 

I want that too :-(  cant see any blood splatters on the walls and or floors. 

 

im from the netherlands and we dont have any censorship here.



#16 Evan_

Evan_

    Disciple

  • PC Member
  • 256 posts

Posted 23 April 2013 - 05:11 AM

Do you use Steam version? Can you enable PhisX?

 

From what I heard, those two can be the cause of not seeing blood. Can't comfirm either, as I can't enable PhisX, even though I have a vid-card that should support it according to the manufacturer, and I'm lazy do download the steamless version with a lousy college net. :-]



#17 OvrTehBottm

OvrTehBottm

    Silver Initiate

  • Master
  • 25 posts

Posted 23 April 2013 - 05:58 AM

Lets hope! But are you sure its feasable with AMD cards? I always thought PhysX was only with NVIDIA? And also, what does enabling PhysX actually do in the game?

 

You can create a Hybrid AMD / nVidia system for PhysX.  You will need to buy an nVidia card within a few generations of your AMD to keep any performance drop to a minimum.  Utilizing a Sapphire 5870 I hybridized with an old nVidia 285, the combo did very well on current generation games.  However, there was noticible fps loss at max settings. If I was to rebuild a Hybrid AMD/nVidia with my current Tahiti based 7870, the nVidia portion would be either a 460 Ti or 560 Ti.  Both of those nVidia cards should have more than enough power to handle the PhysX without breaking the bank.

 

Here is a link to the hybridize setup I used:  http://www.ngohq.com...285-solved.html

 

I should note that you will need to remove PhysX files from the directory of any game that uses PhysX.  There isn't a set pattern to the files as some games will use one file whereas another game will not.  It may sound like a major pain in the ass, but honestly it is quite simple and there are many 'benchmarks' that will allow you to test functionality.  MSI has one such benchmark.

 

Good luck.


Edited by OvrTehBottm, 23 April 2013 - 06:08 AM.


#18 CubedOobleck

CubedOobleck

    Eagle

  • PC Member
  • 2102 posts

Posted 23 April 2013 - 06:09 AM

I saw pics and videos of warframe with with physX enabled and it looks gorgeous, but it also seems bothersome to play with with all that glowing stuff in your face. I was wondering if the physX effects might be less distracting if you disabled bloom(gloom?) in the game options and I was hoping someone might take some screenshots to show me :]

Edited by CubedOobleck, 23 April 2013 - 07:03 PM.


#19 Diagonally

Diagonally

    Initiate

  • PC Member
  • 8 posts

Posted 24 April 2013 - 03:26 AM

First off, I'd like to commend you on your hard work in putting together this awesome guide. Whilst I still couldn't get the Enable PhysX checkbox to work, my graphics and fps improved by a mile (my drivers and processor were years old and I needed to run windows update which hadn't been run since 2009).

 

In regards to this:

 

I couldn't get past step 3.4, there was no preferred graphics processor.

 

 

About step 3.4, even tho you can't do that on the Global Settings tab, can you still select the Nvidia High-Performance Processor on the individual Program Settings tab? I've researched a little and found no one who couldn't see the nvidia one on the list.

 

I also had this problem. The drop down box to select the High-Performance Nvidia Processor seemed to be missing in both tabs. After doing my research I've found that, to my dismay, this feature is only available to those with Nvidia Optimus Technology (which I don't have). Here's an alternative you can try:

 

- Right-click on your desktop and open up the Nvidia Control Panel.

- Click View/Desktop (whatever is provided) and Add "Run with graphics processor" to Context Menu.

- Close the Nvidia Control Panel.

- Right-click the application and select Run with graphics processor and click High-Performance Nvidia Processor.

Unfortunately, this didn't work for me either (the option didn't show up), but it might do for you; try it out!

I want to test the theory that PhysX doesn't work because of Steam, will get back to you guys shortly...


Edited by Diagonally, 24 April 2013 - 03:31 AM.


#20 Redbull102

Redbull102

    Silver Initiate

  • Hunter
  • 31 posts

Posted 26 April 2013 - 02:41 PM

PhysX works with my steam client of warframe.

GTX670 here.

 

Driver are 314.22 for 64bit systems.


Edited by Redbull102, 26 April 2013 - 02:43 PM.