Jump to content

New kitguns, moa, and k-drive not to be found in profile > equipment


THE_ZEEK
 Share

Recommended Posts

  • 2 weeks later...

I even made 4 gilded kitguns, and all I'm seeing is 1 slot, which says;

Kitgun
Unranked

Used 0.0%
Xp 0%
Kills 6
Kill assists 0
Accuracy 60%
Headshot kills 1

It even shows a blank window. No kitgun of any type is displayed whatsoever.
While having 4 gilded ones that have had quite their use in battle allready.

Moa is even nonexistent.
And thus I know not, whether I need to build the other 2 'head' versions and gild them too, for experience as well.
If they even grant experience in the first place.

Link to comment
Share on other sites

3 minutes ago, AegisAmaranth said:

I even made 4 gilded kitguns, and all I'm seeing is 1 slot, which says;

Kitgun
Unranked

Used 0.0%
Xp 0%
Kills 6
Kill assists 0
Accuracy 60%
Headshot kills 1

It even shows a blank window. No kitgun of any type is displayed whatsoever.
While having 4 gilded ones that have had quite their use in battle allready.

Moa is even nonexistent.
And thus I know not, whether I need to build the other 2 'head' versions and gild them too, for experience as well.
If they even grant experience in the first place.

All my Kitguns have 2 - 4 formas in them, one is now my go to secondary as it has a riven and I am seeing the same kind of thing as you are 🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...