Jump to content
Dante Unbound: Known Issues ×
Dante Unbound: Share Bug Reports and Feedback Here! ×

Very Confusing Strict Nat Issue. [Pix]


Recommended Posts

Yeah, I had this as well. Kinda weird, to be honest.

Most people haven't get rid of their Strict NAT just by forwarding the ports or whatever.

Check your firewall or the router's firewall if they are blocking Warframe in any way. Might help.


"Router Firewall"?

Link to comment
Share on other sites

No. That is the whole point of UPnP. 


Sometimes I still get Strict NAT error when everything is actually fine. 


In some cases, it's acceptable that they do not match. Warframe is not one of those cases and it breaks if the port pairs don't match.


Going by OPs photo, Warframe is running on three PCs (or has ports forwarded to 3 IPs in the upnp table, possibly due to DHCP changes) but all three are running on the same ports. Since upnp appears to be working, changing the ports used in the in-game menu and restarting ought to fix it.


As to your assertion that mismatching ports are OK for Warframe, here is why that is incorrect:

When warframe conducts a NAT test, it sends out a test packet saying what port it is using. Normally, this is sent from the same source port that the game is advertising it is running on. In a direct connection or proper NAT, the game sends a packet from 3962 saying "HI! I'm using port 3962."

When the router is rewriting the port, as in this case, the game is sending a packet from 3962 on the local PC, but the router changes the packet source port to something else, like 3964 but the content of the packet still says "HI! I'm using port 3962." The Warframe matchmaking servers don't catch this inconsistency and respond on 3962, the port the packet is advertising and not the origination port on the router. The response comes back on a port the router is either configured to send to another PC or is not configured for at all; thus you then get a NAT error. It's also possible that it is catching the inconsistency and throwing a NAT misconfiguration error. The ports are expected to be the same.


If Warframe paid attention to the source port on the packet and responded on 3964 like the router is advertising then yes the upnp rewriting would work as you say. But it doesn't and it's doing something else instead.


Source: I'm a certified networking tech and I do this stuff all the time. My example may not have the exact port instructions the game uses, as I don't have access to the networking code, but the general principle should be clear enough.


EDIT: The client/server interaction might be more complex than my example but suffice to say I've seen it not work whenever port rewrites are at play.

Edited by Raelus
Link to comment
Share on other sites

Had two friends with this issue and both were because of windows firewall blocking some features of warframe. They were easily fixed by going into the firewall and deleting warframe from the allowed section. Then restart the game and when it popped up choose always allow and this resolved the issues.


Alternatively you could just turn off the windows firewall (as long as you are behind a router) as it is rubbish. Also note that some anti virus (Norton being a major culprit) will block certain aspects of warframe from connecting properly so make sure you allow it through in your virus scanner etc. Hope this helps a bit as it has fixed issues for people, give it a try.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...