Jump to content
  • 0

Mac wineskin crash after updating TWW.


ToaPhantom
 Share

Question

If anyone here is using a Wineskin to play Warframe on Mac, I have a feeling most of you probably had the thing update fulled but before the "Play" could be pressed, The launcher says

"Update failed!

The preprocess pass appeared to crash.

If possible please step through the crash-handler and note the WAR-number you were given when it co- "

I'm not sure how many of you have solved this and are able to play The War Within but i can't. I haven't found a way to fix this and i need some help.
Please answer seriously, don't give any troll answers like "Buy a PC" or "Why would you even play on a Mac" or "Use Bandicamp"(I don't have a place to install or download one). My family is a Mac family, ok? If i had the money to buy a PC i would but i don't.
Any Mac users who use Wineskin to play Warframe, if you have fixed your crash problem, please answer. If i don't have a solution, i don't think i can play Warframe until i'm working and earn money to buy a PC.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I'm pretty sure Boot Camp is your only option for playing on a Mac that has any chance of being supported in the slightest.  Boot Camp itself is free, and you can it install on any Mac with enough hard drive space.  Unfortunately, you will still need a Windows license to actually install Windows.

Link to comment
Share on other sites

  • 0

Had the same problem when 19.0 went live, and eventually just gave up and turned to the family PC so I could run the quest.

That aside, I went digging through some of the Linux user threads, and actually found a solution that worked via this thread. By uninstalling engine 1.8.5 and switching to 1.8, it actually functions just fine for me now. I saw in another thread regarding this issue that you already had vcrun2015 installed, so no need for me to touch on that. Duly note, it took about an hour for the "Checking for new content..." to go away, but it ran fine after. If it starts whining (no pun intended) about not having XAudio2 Engine installed, just run xact_jun2010 and it should be okay.

Best of luck, and hopefully it works for you!

 

Edit: Tested all the way up through engine 1.9.21, and 1.9.17 seems to be the most recent functioning one (that I can see anyways). Some odd crashes regarding certain transmissions in missions, but aside from that it's working fine for me.

Edited by Aeroletian
Tested other engines more thoroughly.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...