Jump to content
General Bug Report Guidelines - Please Read ×

Some mods not working as intended


(XBOX)JjOoZsAeY
 Share

Recommended Posts

Recently i noticed that the umbra mods bonus was not activating on exalted blade on umbra. Second physique not giving inaros more health. Im not sure if its been mentioned before but there are several issues and bugs like this. My apologies if this was already mentioned just delete the thread. Thank you

Link to comment
Share on other sites

20 minutes ago, (XB1)JjOoZsAeY said:

physique not giving inaros more health

Are you talking about in-mission, or in the Arsenal?

Because for the latter, Aura effects don't show up in the Arsenal
(Simulacrum Arsenal might be different, not sure).

Also, pretty please, use a different Aura if possible. Physique is terrible, period.

Link to comment
Share on other sites

2 minutes ago, NinjaZeku said:

Are you talking about in-mission, or in the Arsenal?

Because for the latter, Aura effects don't show up in the Arsenal
(Simulacrum Arsenal might be different, not sure).

Also, pretty please, use a different Aura if possible. Physique is terrible, period.

I wasnt going to use physique, i was just equipping it for fun for max health build.  You are correct though the aura mod physique is working in mission not in arsenal. However, the umbra mods on exalted blade still not getting the bonus. Thank you

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...