Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×

global game version censored ?


JBigRun
 Share

Recommended Posts

hey everyone,

I recently noticed that the kill animation with a sword seems to be censored because the

extremities of the enemy's can't get cutted off like in the alpha gameplay videos on

youtube. Is this true, and if so, any chance to re-enable this ?

The game should feel a bit more like Dead Space ( just a little bit ) :D

Greets.

Link to comment
Share on other sites

yep, there is gore with the charged attack but no flying body parts. :D

seems like for some countrys there is a "lesser violance" version. hm...

Well it might be due to region restrictions.

I know this was the case for L4D, Dead Space, Dead Island, Manhunt.. Etc.

Or maybe it's a settings thing.

What graphics settings are you on?

Link to comment
Share on other sites

... I am from Germany. The only other country hit by censorship as much as we are is Australia.

Yeah so it's probably not a censorship thing then. Most likely settings, or.. The OP is not satisified with the blood he is getting and is expecting Unreal Engine chunks of flesh.

Link to comment
Share on other sites

it might be PhysX thing you lacking i am not really knowledgable about it but in Borderlands 2 it was adding alot of effects like pebbles coming of ground when you shoot at it(wich made good fps drop on my low PC) and you could turn it off\on, could be client just off's it on default due to low PC spec. dont have gore myself but i certanitly can hear sound effects for it but yet to find where to turn on\off PhysX i just hoping if i manage to enable "gore" it will not drop my FPS alot, as it is game runs pretty smooth with occasional spike in fps wich is not big deal(some some staggering with 4 people, 3 or less still smooth)

Link to comment
Share on other sites

I think I've found the problem with it.

Nvidia APEX, for realtime physics calculations.

I'm using an ATI Readon Card. Maybe it does not support that.

On the other hand, PhysiX by Nvidia seems to do it's job for me.

Is it possible to install the apex driver on my own or is it simply not supported ?

Link to comment
Share on other sites

I think I've found the problem with it.

Nvidia APEX, for realtime physics calculations.

I'm using an ATI Readon Card. Maybe it does not support that.

On the other hand, PhysiX by Nvidia seems to do it's job for me.

Is it possible to install the apex driver on my own or is it simply not supported ?

Nope, I'm no AMD, and I have all the guts and gore. What settings in game are you running?

Though I could've sworn that made no difference, as I tried it on every setting and I'm pretty sure there was gore anyway.

Link to comment
Share on other sites

I mean, one of the sliders might actually controls the gore effects. Like graphics details or something.

Oh yeah, but I've played on low, medium and even high, and I never noticed missing gore.

In fact on my weaker laptop I'm playing it on all low, and I still have gore.

Link to comment
Share on other sites

Oh yeah, but I've played on low, medium and even high, and I never noticed missing gore.

In fact on my weaker laptop I'm playing it on all low, and I still have gore.

Then it have to be the game's bug since some people don't have them and the effects are confirmed to be available also on low settings.

And don't tell me the game actually have an IP filtering and changes the game graphics according to where you live. That's absurd (lol).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...