Jump to content
General Bug Report Guidelines - Please Read ×

Glaive - Testing And Bugs


Recommended Posts

NOTE: The Kestrel seems to have the same issues, as it must use the same code.


I have been using a standard Glaive extensively recently, as the only weapon for the entire mission, so I have noticed a lot of issues. I'm hoping to maybe even get other people that use them currently to see this and post anything they might have on the Glaive and Glaive Prime as well.


I will list in point form and explains the ones I can, and list ways to duplicate the ones I actually managed to do. (*) means longer description below.


*1) Glaive won't return (uncommon, maybe 1-10 missions)

*2) Character locked in "Glaive draw" animation (can replicate)

*3) Lose ability to use ANY guns and or even jump (rare)

*4) Have Glaive, but unable to attack or throw, either equipped or via quick throw (uncommon, maybe 1-5 missions)

5) If a Volt activates "Speed", it seems impossible to throw Glaive when equipped. You just get a melee animation. I think it's because of the increased attack speed, so the launch animation never takes place.

6) If Valkyr activates "Warcry" the same thing happens as with Volt "Speed".

*7) It seems to be possible to accidentally do a "slam" animation, usually when going from a higher ground level to a lower one, like on a ramp or barrel, and when this happens, you lose ability to attack, throw, or even switch weapons. (can "unstuck" this by using an ability most times)

*8) Power Throw mod : With Power Throw equipped (just got that mod) Glaive explodes on it's own MOST times on the last bounce. If this happens to be near user, it will of course damage them.

*9) If bounced into a surface and get a direct hit on Frame after a single bounce, Glaive explodes. Not sure if normal. Tested a few times against a pillar. Had Power Throw equipped, need to retest without.


EDIT (18/08/14) : I have now (4 times) "reset" a stuck Glaive by killing myself by falling into a "reset" zone, like jumping off a cliff or into a pit etc. ALSO FOUND instances where this does NOT work, so I'm stuck with no Glaive for that mission.



1) Randomly, Glaive will fly out but simply not return. Sometimes, after an extended period, it does appear back for use. I do not yet know if it's because it got stuck "somewhere" and I simply walk past that spot, or some internal reset happens. I will need to leave a tile and wait someplace without moving and try things like swapping weapons and re-equipping to see if the action manages to "fix" itself.


2) If you change between say, primary and Glaive very fast while at the same time hit the attack button, it will get stuck in an interim throw animation. Basically it's as if you "drew" the Glaive, and just as you attacked, you switched to a gun, but instead of switching, it removed the Glaive from your hand and STILL tried to throw it, and gets really confused and the action never finishes. If I also now try to hit "switch weapon" again, the action can glitch even more.


Doing this will cause you to lose ability to change to any guns, leaving you defenseless. I seem to be able to "fix" this by spamming jump/roll/attack. Will retest with less keys later.


3) After a throw with the Glaive not returning (best guess), character remains empty handed, and weapon swithing, jumping and attacking has no visible effects. Could wallrun, did not get a chance to try using abilities. I was actually stuck behind a destroyable grate, and actually thought  could not exit the level, but for some reason, my Sentinel shot it, allowing me to continue to extraction.


4) Glaive returns and is visible in hand if equipped, but cannot attack with it, or throw it, either quick or equipped. Able to switch to primary/secondary and kept switching back to Glaive every so often to see it it "unglitched", but had to run the entire level with guns every time this happens.


ADDED: I had it happen just jumping off a ledge and landing. Upon touching down, no ability to swing Glaive, or throw, I think while I was in mid air I either auto-blocked (Reflex Guard) or reflexively tried to throw at a camera. Very hard to reproduce as it happens VERY unexpectedly, and me re-jumping that spot produced no results.


ADDED: Had Glaive in hand, but could not attack or throw. I was walking around and heard the Glaive "spinning sound". Located Glaive  3D model up in some pipes. I was holding a copy, and the "original" was stuck there.




I climbed up there, but being right next to it does not make it come back. Left tile. came back. Glaive model and sound gone, but still no working Glaive. Almost could not finish Extermination mission from lack of Primary ammo :) almost ...


Have tried to fall into a "reset" zone to reset it. It did not work (1 time)


7)  This happens quite a bit. It looks like a normal slam, but much shorter and without jumping high first, It's quite easy to do in place of a normal attack, but only seems to happen on not level terrain. I seem to be able to get the Glaive back by just using an Ability, but until you let something off, you are unable to attack with it. If you keep hitting "swap" it eventually unstucks, either that or after a random time interval (needs testing, usually I'm getting shot at), as far as I can tell, just firing off an ability, even ability 1, will fix this problem (99% as far as I know)


8) Probably 9/10 times, with Power Throw equipped, Glaive explodes on last bounce. Some surfaces will also cause Glaive to exlode on first contact, some walls will do it only in certain spots (possible a very fast bounce jitter that is impossible to see visually?) and had it happen firing at a cargo container. Will retest on a level.

Edited by DSpite
Link to comment
Share on other sites

A big problem is whebn the glaive flies out and gets stuck in the ceiling, usually also in the corners of rooms then it won't return. Sometimes, you get it back, but cannot swing at all. This is extremely problematic, especially if you are using the glaive combo and it gets stuck mid combo. Then you have a spinning disk doing nothing in the middle of nowhere

Link to comment
Share on other sites

there should be a reset feature after a glaive has been flying for more than 5 seconds.

I often find myself useless waiting for the damn thing to return


That kind of thinking leads to other problems. I'm sure the Glaive code has already a lot of checks, we don't know exactly why it gets stuck, I'm just pointing out to DE it's behavior, and I'm sure they will know why.


The instance seem related to some specific map terrain, and I have tried pretty hard on purpose to confuse it, and it always comes back. It seems to happen only after some type of target impacts and bounces, so It may only happen in combat.

Link to comment
Share on other sites

  • 4 weeks later...

+1 OP


i would really like to see these get addressed


would also be nice to just throw while equipped instead of the stupid atk-then-hold bs, just hold is so much easier (ironic that it is easier to throw the glaive while you have another weapon equipped than when you are just holding the glaive)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...