Jump to content
General Bug Report Guidelines - Please Read ×

Arbitration WF 300% str bonus bugged


TheBlackAce21
 Share

Recommended Posts

Ok so I have noticed this with 2 warframes so far but I only have visual evidence with one of them. I had a bonus for Hydroid and I made a build with like 90% duration, 175% eff, 250% range, and 40% strength. Undertow should have had just over 6% damage increase/s but only had like 1.7 because 40%+300% = 340%

Now at first I just thought this meant that the +300% was multiplicative and 40%x3 = 120% which still shoulda been over 2% damage increase/s but I thought perhaps it was some kind of weird math. Until I took Ivara into one with the augment for crit damage on ziplines. My base str was 200% and the buff was at 500% which clearly meant it was additive.

Now comes the final straw. Chroma buff. Much excite. I was planning on bringing in an everlasting ward build to give crazy resist buffs. I was leary however from the weird math I had already seen by now and I was paying closer attention to the stats. Here are the stats before the mission (as a side note, pre mission ability screen doesn't seem to show Elemental Ward stats for the current selected color so thats another bug).

e38m5H8.jpg

 

Now here is the abilities screen from the escape menu ingame, and before anyone asks, yes I tested the buffs for vex armor by purposefully taking damage and maxing it out. They are the same.

XpvYcvy.jpg

 

Now idk if this is intentional and if it is, it really shouldn't be because I don't care how strong the frames are, saying a frame gets +300% str should mean it gets +300% strength. I find it more likely it is a bug since it didn't apply to ANY abilities instead of just not applying to certain ones. Hopefully it is a bug and gets fixed quickly. Thanks for your attention in this matter :)

 

::edit:: Others have posted and taken the time to test specific frames, going to link their posts as I see them for visibility reasons

 

Edited by TheBlackAce21
Additional info
Link to comment
Share on other sites

Actually I have noted the same thing as you did, and even if I don't have taken proof of my claim, here is my guess based on some little testing : The bonus work... but not on prime variant.

I dunno if the bonus work on weapons variants. Oh and don't forget it's only a guess, I don't have warframe in double, so I only checked by comparing when I had the normal one to do it, it worked perfectly, but never when I had a prime one. So maybe it's only certains warframe.

Edited by Kur0Shir0
Link to comment
Share on other sites

I ran into the same issue with Chroma Prime and a few other Prime frames so it seems like the bonuses are hyper specific. In other words, Prime frames won't get the bonus unless specifically stated as such and I assume the same to be true for weapon variants. Seems like an oversight and hopefully this is addressed as I sold my normal frames once I acquired the Prime version so I would be missing out on most of the buffs going forward. I'd hate to have to build the normal variants again just to enjoy these buffs.

Link to comment
Share on other sites

I've had the same issue on Hydroid Prime and Rhino Prime so far.  Rhino Prime was for sure not receiving the bonus because my damage buff on my roar was the normal percentage, and my iron skin and bonus armor from Ironclad Charge were at their normal values.  I don't think it's a universal prime frame issue because I used Frost Prime and was stripping 100% of armor from enemies with my 4 in spite of being at max range with 40% strength without the bonus, and I used Trinity Prime with 40% strength but had 75% DR on Blessing.  So it's either specific to certain primes that they overlooked, or it has nothing to do with primes at all.

I think I probably won't bother with using the bonus frames anymore until this is fixed.  They're often not an optimal choice even with the bonus, anyway, but I liked experimenting and using high range, high strength builds that wouldn't normally be possible.  However, if I can't rely on the bonus to apply, it's not worth bothering.

Edited by JP_Russell
Link to comment
Share on other sites

Yea I think it might be something with certain prime frames as well, I have a buddy who was using Oberon Prime and getting a 1000 armor buff with 200% strength which would be in line with the base numbers + the bonus. I have yet to see it happen with a non prime frame but I will keep my eyes open just in case it is related somehow. I doubt that it is intentional and I hope like all of you that it gets fixed soon 😞 I want to be able to use my prime frames with that sweet sweet bonus xD

Edited by TheBlackAce21
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...