Jump to content

Fortuna frame rate issues


(PSN)trixydog123
 Share

Recommended Posts

I have a 1050ti, a Ryzen 3 (3.2Ghz) and 8GB of DDR4 ram (3200MHz). I can clock a solid 60fps on the plains (on the highest graphics preset). But on Fortuna I can't even keep a steady 40fps. Frame times are also very uneven. It gives me a headache to play. Turning down the graphics setting does not help. I'm playing at 1080p.

Link to comment
Share on other sites

It definitely needs some ironing out expect them to make it smoother for players in the future 

 

My build while on maxed settings @2560x1080

EVGA GTX 1080 Hybrid

i7 6700K

G.Skill 32GB memory

 

And i do encounter some hiccups, but the only real negative impact though is when i'm zooming with snipers other than that it's mostly smooth 

Link to comment
Share on other sites

33 minutes ago, (PS4)trixydog123 said:

I have a 1050ti, a Ryzen 3 (3.2Ghz) and 8GB of DDR4 ram (3200MHz).

Your machine should run game smoothly,any present game actually.Maybe not on high settings but it is solid machine.

Something is definitely wrong with Fortuna.I can run any game and I never had any problems with Warframe,not even with PoE.Fortuna however ,is totally unplayable for me.

AMD hexacore 3,2Mhz ,8gb DDR3,Radeon HD 7700 2 gb.

Edit:

Forgot to say that I have all settings on low and every effect on off.I even lowered my resolution from 1920x1080.

Edited by RistN
Link to comment
Share on other sites

5 minutes ago, RistN said:

Your machine should run game smoothly,any present game actually.Maybe not on high settings but it is solid machine.

Something is definitely wrong with Fortuna.I can run any game and I never had any problems with Warframe,not even with PoE.Fortuna however ,is totally unplayable for me.

AMD hexacore 3,2Mhz ,8gb DDR3,Radeon HD 7700 2 gb.

I can run almost all games on high settings at 60fps at 1080p. I'm hoping as a previous post said the anisotropic filtering is bugged. Normally I can run Warframe without breaking a sweat.

In your case you might struggle with only 2GB of VRAM on fortuna

Edited by (PS4)trixydog123
Added detail
Link to comment
Share on other sites

24 minutes ago, OriginalBoss said:

It definitely needs some ironing out expect them to make it smoother for players in the future 

 

My build while on maxed settings @2560x1080

EVGA GTX 1080 Hybrid

i7 6700K

G.Skill 32GB memory

 

And i do encounter some hiccups, but the only real negative impact though is when i'm zooming with snipers other than that it's mostly smooth 

With a £2000+ machine I'd hope you could run it smoothly 🙂

Link to comment
Share on other sites

 

15 hours ago, Gabbynaru said:

Turn off Anisotropic Filtering. That's the thing that kills the framerate. It's bugged.

(Also, how did you manage to get Fortuna on PS4 so quickly?)

 

Anisotropic filtering changed EVERYTHING for me in Orb AND PoE!!! I have a 1050 ti and Im running everything at maximum again (except Anisotropic filtering as of now) and its all perfect again! Just turn it off, its GLORIOUS!!!!!!!!!!!!!!!!!

THANK YOU GABBYNARU!!!

I AM SO HAPPY!!!!!!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...