xLycan

Loading Screen Stuck When Using Directx 10

Recommended Posts

If I tick direct 10x in the warframe launcher, the loading screen will always freeze for 2-3 mins and work again. This has caused me a lot of trouble as I cant play any missions and always get kicked out because I spend too much time in the loading screen. When I turned directx 10 and use directx 9 everything went normally without any freeze. Anyone knows any solution? 

NOTE: I won't be able to use directx 9 in the future because DE is gonna remove it. Hence I need a solution so I can play with directx 10 after 9 is removed

Sorry for my bad English as it's not my native language

Edited by xLycan

Share this post


Link to post
Share on other sites
1 minute ago, xLycan said:

Windows 7

Well, W7 supports DX11. Use it.

DX10 is really bad. It have a lot of problems with rendering and compatibility.

Share this post


Link to post
Share on other sites
12 minutes ago, xLycan said:

For some reason I cant use dx11 even though mine supports till dx12

Strange, is your W7 32 bits?

Whats your PC specs?

Share this post


Link to post
Share on other sites
1 minute ago, -SDM-NerevarCM said:

Any dedicated VGA?

VGA? I don't quite follow

Share this post


Link to post
Share on other sites
3 minutes ago, -SDM-NerevarCM said:

Any dedicated VGA?

Are u referring to dedicated video memory? If so, no

Share this post


Link to post
Share on other sites
Just now, xLycan said:

Are u referring to dedicated video memory? If so, no

Really strange, did you download new drivers? Up to date drivers

Share this post


Link to post
Share on other sites
10 minutes ago, -SDM-NerevarCM said:

Really strange, did you download new drivers? Up to date drivers

Where can I get those

Share this post


Link to post
Share on other sites

Is that the reason why I can't play?

Edited by xLycan

Share this post


Link to post
Share on other sites
1 minute ago, xLycan said:

Where can I get those

First check the manufacturer of your graphics card. NVIDIA, INTEL or AMD. Then go to their site and download the latest driver for your graphic card.

Share this post


Link to post
Share on other sites
1 minute ago, -SDM-NerevarCM said:

First check the manufacturer of your graphics card. NVIDIA, INTEL or AMD. Then go to their site and download the latest driver for your graphic card.

I don't have a graphics card :P

Share this post


Link to post
Share on other sites
36 minutes ago, xLycan said:

64 bit i3 processor 6gb ram

I need to clarify this here. Your Windows OS isn't the same as your processor. Meaning that If your processor is 64 bit it can install the OS either 32bit or 64bit. You'll need to check your Windows OS system type, it should say '64-bit operating system, x64-based processor'. If it say 32 bit, you'll need to install new OS that support 64 bit (you'll need a professional to do this, but it'll wipe your data clean).

Also, If you don't have a graphic card that is mean you either using Intel/AMD integrated graphic system. Look for your processor model number and you can search that in google easily.

Edit : ops, you just said i3... which mean you're using Intel HD graphic card. just search intel model number you're using and it should link you to intel website.

Edited by NocheLuz

Share this post


Link to post
Share on other sites
7 minutes ago, xLycan said:

I don't have a graphics card :P

 

Just now, NocheLuz said:

Also, If you don't have a graphic card that is mean you either using Intel/AMD integrated graphic system. Look for your processor model number and you can search that in google easily.

This

Share this post


Link to post
Share on other sites

So I just need to go to the intel websites driver support and download the program? Is it free?

Share this post


Link to post
Share on other sites
1 minute ago, xLycan said:

So I just need to go to the intel websites driver support and download the program? Is it free?

Yep, just download it, restart the PC and check if the DX11 option will be available in WF launcher

Share this post


Link to post
Share on other sites
3 minutes ago, xLycan said:

I did everything but no luck 😞

Can you tick 64-bit mode in Launcher?

Try using 64 bit mode before using DX11.

Share this post


Link to post
Share on other sites
18 hours ago, NocheLuz said:

Can you tick 64-bit mode in Launcher?

Try using 64 bit mode before using DX11.

Yes I have always ticked it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now