Jump to content

Archived

This topic is now archived and is closed to further replies.

Phazerade

FIX for most Update Failed! and Launcher Errors!

Recommended Posts

so guys i have solution for this problem!, yesterday im trying to install directx and then voila! now u can playing this game normally but im sorry if my solution not working with u guys. i hope u will get the solution soon..

 

im sorry if my english bad :blush:

Share this post


Link to post
Share on other sites
On 2017. 10. 23. at 11:04 PM, Phazerade said:

I have been searching for this fix day and night for roughly 30 hours now and finally got it to work!

If you have been having Bad Image! or Update Failed! errors, this will likely get you back into the game.

If this dosent fix the Launcher for you I apologize, but this is kind of a last resort kind of deal.

Type "uninstall" into your search bar, "Add and Remove Programs" should pop up. Click it.

Type "Visual" into the search bar and several Microsoft Visual C++ 20XX Redistributables should pop up. If they dont you probably have to install them, the lack of proper C++ Redistributables is causing the error for most people. This is often caused by a faulty system update (Thanks Microsoft!) or fooling around with sys32 files by accident.

Starting at 2010 forward (2010-2015 usually), click each and select "Modify" (you may need to right click on each depending on operating system).

Select "Repair" on each window for each one (only repair one at a time, each one should take 5-30 seconds).

Once you have repaired each, run Command Prompt as an administrator and type "sfc /scannow" (no quotes). This will scan your core files and make sure everything looks good.

Restart your computer (the repairs will have no effect until you restart) and re-run the Warframe launcher. It should work.

If this fails, try repairing the C++ Redistributables previous to 2010, then if that dosent work uninstalling and reinstalling each (2010+) off of the OFFICIAL Microsoft website, never download important sys32 files from outside sources.

 

im trying this but not really works, can u make a video? :D

Share this post


Link to post
Share on other sites

I followed he instructions but i only seem to have those of 2017.how do you fix this?although my PC has just been brought to life again with a frsh new start with Windows 10.

 

Share this post


Link to post
Share on other sites

Just +1'ing this issue, tried the fixes suggested and nothing. The fact that it literally cut out mid-game for me though, really looks like a network issue, as if my IP (apartment-complex shares internet) got banned or somesuch. Though, I can login and access warframe.com.... OH. Can't login to warframe app while on my place's wifi, BUT IT CAN ON MOBILE DATA. DE, please try to fix up these auto-blocks that don't even inform us of the issues/causes/reasons?

Share this post


Link to post
Share on other sites
On ‎11‎/‎17‎/‎2017 at 7:07 PM, STATIS said:

Hi all,

Today Microsoft released a huge "Creator Update" for Windows 10 which may be the cause of the issue and is taking many computers hours to fully download and install. If this fixes the issues, the original problem is probably due to the last updates that were preparing for this one. I'll follow up when this finishes and see if there's still more troubleshooting to be done after this listing steps if necessary.

I'm an IT guy and am applying this update across 11 or more PCs now. It's a serious behemoth...

EDIT: The update is Creator Update 1709. Still more updates to follow this one as well.

EDIT2: Went through all updates, reinstalled, applied all troubleshooting/compatibility fixes, still have the connection error. So pretty assured now it's a network issue. Talking with support about the issue further. Also gunna cross out my post.. doesn't add anything to the solution anymore.

for network errors I found a fix to this

when your connected to the network and have no access. im posting this of 2/21/2018 and it has been a recent issue in the past week for me and now I found a fix for the network issue and I run into the update issue this morning but can confirm network function

try these commands

1. run command prompt as an administrator
2. type this exactly as fallows without the quotes

"ipconfig/flushdns"
"ipconfig/release"
"ipconfig/release6"
"ipconfig/renew"

should allow you to connect instantly but remember run as administrator and drop the quotation makes

 

Share this post


Link to post
Share on other sites
On 11/17/2017 at 11:40 AM, BlackMatlock said:

e

 

On 10/24/2017 at 2:34 AM, Phazerade said:

I have been searching for this fix day and night for roughly 30 hours now and finally got it to work!

If you have been having Bad Image! or Update Failed! errors, this will likely get you back into the game.

If this dosent fix the Launcher for you I apologize, but this is kind of a last resort kind of deal.

Type "uninstall" into your search bar, "Add and Remove Programs" should pop up. Click it.

Type "Visual" into the search bar and several Microsoft Visual C++ 20XX Redistributables should pop up. If they dont you probably have to install them, the lack of proper C++ Redistributables is causing the error for most people. This is often caused by a faulty system update (Thanks Microsoft!) or fooling around with sys32 files by accident.

Starting at 2010 forward (2010-2015 usually), click each and select "Modify" (you may need to right click on each depending on operating system).

Select "Repair" on each window for each one (only repair one at a time, each one should take 5-30 seconds).

Once you have repaired each, run Command Prompt as an administrator and type "sfc /scannow" (no quotes). This will scan your core files and make sure everything looks good.

Restart your computer (the repairs will have no effect until you restart) and re-run the Warframe launcher. It should work.

If this fails, try repairing the C++ Redistributables previous to 2010, then if that dosent work uninstalling and reinstalling each (2010+) off of the OFFICIAL Microsoft website, never download important sys32 files from outside sources.

 

 

Hey there

@Phazerade

I tried the steps you listed at the top here and visual c++ redistributable 2013 x86 was giving me an error that I had to reboot my computer before I could repair or uninstall it. Even downloading the redistributable installer from MS website and running it gave the same error.

I tried rebooting of course but it still kept giving me the same error. I tried a lot of steps to get it fixed and wasn't able to get it fixed so I force uninstalled it using revo uninstaller and then I installed a later version (an update I found on MS website) of visual c++ redistributable 2013 x86 on my PC.

I uninstalled and reinstalled all the other redistributables from 2005 to 2015 after that.

The game still would not update.

 

I ran sfc /scannow after that and it was in fact giving me an error but I found a command dism that rebuilds the system file image and ran it and it said it was successful. I also found a program called sfcfix which is supposed to fix a lot of the errors in system files.

 

I also found malware on my system and those have been taken care of.

 

Despite doing all of that, I still can not connect to the game. I have of course done all of the normal steps like allowing the required ports for Warframe in my firewall, verifying cache and so on... I have even tried connecting through VPN but I can not connect Warframe even then so I don't think I am ip banned,

 

I have also contected Warframe support and have been in touch with them since Monday but they keep giving me basic steps like power cycling the router and disabling services in Msconfig despite me telling me I have done all of this stuff..

 

Can you suggest anything further that I can do?

Share this post


Link to post
Share on other sites

My god.. this just basically saved me re-installing warframe.

I followed the steps perfectly the 1st option which Modify everything from 2010-2015 did not work but Reinstalling 2010 (x86) and (x64) worked.it said "checking for new contents" but for a few minutes it finally worked! Thank you for this, this occured when I started warframe in the afternoon until now. :)

Share this post


Link to post
Share on other sites

Turning off bulk download, DirectX 10 and DirectX 11 worked for me. After updating fully i turned these on again.

Share this post


Link to post
Share on other sites

What should I do if I just have 2017 versions? I tried putting in the 2015 version but it says I can't due to having a more recent version.

Share this post


Link to post
Share on other sites
On 2017-10-24 at 2:34 AM, Phazerade said:

I have been searching for this fix day and night for roughly 30 hours now and finally got it to work!

If you have been having Bad Image! or Update Failed! errors, this will likely get you back into the game.

If this dosent fix the Launcher for you I apologize, but this is kind of a last resort kind of deal.

Type "uninstall" into your search bar, "Add and Remove Programs" should pop up. Click it.

Type "Visual" into the search bar and several Microsoft Visual C++ 20XX Redistributables should pop up. If they dont you probably have to install them, the lack of proper C++ Redistributables is causing the error for most people. This is often caused by a faulty system update (Thanks Microsoft!) or fooling around with sys32 files by accident.

Starting at 2010 forward (2010-2015 usually), click each and select "Modify" (you may need to right click on each depending on operating system).

Select "Repair" on each window for each one (only repair one at a time, each one should take 5-30 seconds).

Once you have repaired each, run Command Prompt as an administrator and type "sfc /scannow" (no quotes). This will scan your core files and make sure everything looks good.

Restart your computer (the repairs will have no effect until you restart) and re-run the Warframe launcher. It should work.

If this fails, try repairing the C++ Redistributables previous to 2010, then if that dosent work uninstalling and reinstalling each (2010+) off of the OFFICIAL Microsoft website, never download important sys32 files from outside sources.

 

The Modify option for C++ Redistributables previous to 2010 have their Modify option disabled.Why and what should i do now?

Share this post


Link to post
Share on other sites
On 2017-10-24 at 4:04 AM, Phazerade said:

I have been searching for this fix day and night for roughly 30 hours now and finally got it to work!

If you have been having Bad Image! or Update Failed! errors, this will likely get you back into the game.

If this dosent fix the Launcher for you I apologize, but this is kind of a last resort kind of deal.

Type "uninstall" into your search bar, "Add and Remove Programs" should pop up. Click it.

Type "Visual" into the search bar and several Microsoft Visual C++ 20XX Redistributables should pop up. If they dont you probably have to install them, the lack of proper C++ Redistributables is causing the error for most people. This is often caused by a faulty system update (Thanks Microsoft!) or fooling around with sys32 files by accident.

Starting at 2010 forward (2010-2015 usually), click each and select "Modify" (you may need to right click on each depending on operating system).

Select "Repair" on each window for each one (only repair one at a time, each one should take 5-30 seconds).

Once you have repaired each, run Command Prompt as an administrator and type "sfc /scannow" (no quotes). This will scan your core files and make sure everything looks good.

Restart your computer (the repairs will have no effect until you restart) and re-run the Warframe launcher. It should work.

If this fails, try repairing the C++ Redistributables previous to 2010, then if that dosent work uninstalling and reinstalling each (2010+) off of the OFFICIAL Microsoft website, never download important sys32 files from outside sources.

 

 

Share this post


Link to post
Share on other sites

Alright cool..... 

 

 

 

BUT WHY DOES THE LAUNCHER KEEP SAYING I NEED ATLEAST 2GB TO PLAY THE GAME... I HAVE WAY MORE THEN THAT LIKE TF 

Share this post


Link to post
Share on other sites
On 2017-10-23 at 4:04 PM, Phazerade said:

I have been searching for this fix day and night for roughly 30 hours now and finally got it to work!

If you have been having Bad Image! or Update Failed! errors, this will likely get you back into the game.

If this dosent fix the Launcher for you I apologize, but this is kind of a last resort kind of deal.

Type "uninstall" into your search bar, "Add and Remove Programs" should pop up. Click it.

Type "Visual" into the search bar and several Microsoft Visual C++ 20XX Redistributables should pop up. If they dont you probably have to install them, the lack of proper C++ Redistributables is causing the error for most people. This is often caused by a faulty system update (Thanks Microsoft!) or fooling around with sys32 files by accident.

Starting at 2010 forward (2010-2015 usually), click each and select "Modify" (you may need to right click on each depending on operating system).

Select "Repair" on each window for each one (only repair one at a time, each one should take 5-30 seconds).

Once you have repaired each, run Command Prompt as an administrator and type "sfc /scannow" (no quotes). This will scan your core files and make sure everything looks good.

Restart your computer (the repairs will have no effect until you restart) and re-run the Warframe launcher. It should work.

If this fails, try repairing the C++ Redistributables previous to 2010, then if that dosent work uninstalling and reinstalling each (2010+) off of the OFFICIAL Microsoft website, never download important sys32 files from outside sources.

 

It worked for me THANK YOU!

Share this post


Link to post
Share on other sites

Guys change language and then wait for update it will fix it then you can choose your language again ^^ I had that error it fixed mine

Share this post


Link to post
Share on other sites

I Also asked DE to fix that, And they actually responded but I didnt understand anything because I dont know any of that technical things in my computer and I just realised I sounded like a old man, And I also saw this and bassicly I look like a monkey trying to play tetris, WHile you are like I dunno.

Share this post


Link to post
Share on other sites

I did the first procedure and it didn't work for me. Then, I ran the launcher as admin and it started updating properly. THANK YOU!

Share this post


Link to post
Share on other sites

I was having this problem on both steam and the lone launcher and I tried the Visual C++ stuff but it didnt work. I quit out of Discord and it immediately worked on both steam and the launcher.

Share this post


Link to post
Share on other sites
47 minutes ago, meeeeeeeeeeeeeeme said:

I was having this problem on both steam and the lone launcher and I tried the Visual C++ stuff but it didnt work. I quit out of Discord and it immediately worked on both steam and the launcher.

If Discord tries to put its overlay on the Warframe launcher, it breaks the launcher. Go into Discord settings and remove Warframe from the list of games to put the overlay on.

Share this post


Link to post
Share on other sites

×
×
  • Create New...