Jump to content
General Bug Report Guidelines - Please Read ×

Syndicate Sigil disappears after selecting in arsenal/appearance


(XBOX)erbe3772
 Share

Recommended Posts

Whenever I equip a sigil in the arsenal (yes, I do actually click on EQUIP..) it appears just fine on my frame whilst I'm in the arsenal, however when I exit out of the arsenal, the sigil disappears from my frame.

No, I do not get syndicate standing so it's not just invisible.
Yes, I already verified game cache.
I have never been able to equip a sigil and already been playing for a few days, so I need an answer on this..

Ty

Link to comment
Share on other sites

it happens to me too. I haven't tried to all my warframes, but my main WF is Nezha and he couldn't use syndicate sigil too, stalker sigil is fine. I tried using Ember and Wukong, they did fine. so in my case, it's only Nezha.

Link to comment
Share on other sites

Posted (edited)

Since the update, one of my appearance tabs for Valkyr can't keep any of the Steel Meridian sigils equipped either.

This is weird, because all the other five appearances have no issue with this. Nor do the other frames, as far as I noticed.

I tried taking things off, changing skins, etc. for that one tab to see if it would help, but nope. The other sigils I tested were fine too.

 

For a complete bug report, here are the steps that create the issue for me:

  • select the problematic Appearance tab
  • equip any Steel Meridian sigil (front or back does not matter)
  • admire how the sigil looks on the frame in the Arsenal
  • exit the Arsenal, to find the sigil gone
  • re-enter the Arsenal, where the respective sigil slot is now empty
Edited by Aeoni
Link to comment
Share on other sites

vor 3 Stunden schrieb Aeoni:

Since the update, one of my appearance tabs for Valkyr can't keep any of the Steel Meridian sigils equipped either.

This is weird, because all the other five appearances have no issue with this. Nor do the other frames, as far as I noticed.

I tried taking things off, changing skins, etc. for that one tab to see if it would help, but nope. The other sigils I tested were fine too.

 

For a complete bug report, here are the steps that create the issue for me:

  • select the problematic Appearance tab
  • equip any Steel Meridian sigil (front or back does not matter)
  • admire how the sigil looks on the frame in the Arsenal
  • exit the Arsenal, to find the sigil gone
  • re-enter the Arsenal, where the respective sigil slot is now empty

exactly my issue.. thank you for the complete description of the bug. additionally, boss sigils work just fine. it's just syndicate sigils.

  • Like 1
Link to comment
Share on other sites

I have been unable to attach a Syndicate sigil to Mag; I can select them from the sigils menu, they appear on Mag, persist through the rest of my time in the menu, and then unequip as soon as I return to gameplay.  This affects the Arbiters of Hexis, Cephalon Suda and Steel Meridian sigils; I don't have the other three so I haven't tested those.  Notably, this does not affect any of the cosmetic sigils, such as those dropped from Assassination targets.

This does not seem to affect any other Warframe that I have tried, including other female type frames.

Link to comment
Share on other sites

Posted (edited)

Not entirely sure what's going on here, but I can confirm the following:

  • Issue appears to happen on all platforms (was seen on PC , Sony and MS consoles).
  • Issue also appears to affect pretty much all Frames (Had it on my starter frame Excalibur on an alt account, and this topic has many ppl using other frames and getting it)... Which really sucks since it means I'm litterally unable to rank up any syndicate till this gets fixed... But it might not affect cosmetic loadout B for some reason.
  • Issue might only affect the starter sigil with no % . If anyone could confirm if it also occurs on higher % sigils, it would be appreciated (not gonna unequip mine for now for obivious reasons).
  • Issue doesn't seem to affect sigils that were already in place on existing frames (at least my old frames are still earning their standing normally, but if you attempt to put a sigil on a frame that doesn't have a sigil yet , it will auto-unequip / vanish after leaving the customisation screen.

There's also the recent and annoying issue where Sigils had they vertical X and Y positions swapped in the menu, meaning if you had manually altered the X and Y positions in the past to , let's say , put your sigil at their lowest position, they will now appear on your neck... Thus if you could also fix this while fixing the more aggravating issue, would be appreciated. Really doubt us vets want to spend hours going throug 50+ frames's ABC loadouts and reajust every front and back sigils due to an inverted menu setting.

Edited by (PSN)Stealth_Cobra
Link to comment
Share on other sites

1 hour ago, (PSN)Stealth_Cobra said:

But it might not affect cosmetic loadout B for some reason.

For me it affected C but not A or B and only on one frame.  It was the frame I used for the new quest, but I can't remember if I switched to that appearance before the update or between updating and starting the quest.

1 hour ago, (PSN)Stealth_Cobra said:

Issue might only affect the starter sigil with no % . If anyone could confirm if it also occurs on higher % sigils, it would be appreciated

It was the Assassin Sigil (top level Red Veil sigil) that I had equipped already and then noticed had disappeared and couldn't be re-equipped.  I tried various sigils of different percentages and differnet Syndicates but none stayed.

1 hour ago, (PSN)Stealth_Cobra said:

There's also the recent and annoying issue where Sigils had they vertical X and Y positions swapped in the menu,

This has been fixed on PC, don't know if it has made it to consoles yet, but it swapped everything back so the Operator/Drifter appearances and half a dozen warframe appearances I had fixed manually got broken again!  😄

Link to comment
Share on other sites

On 2022-05-09 at 11:02 PM, (XBOX)Neonflux23 said:

I'm still having this issue (seemingly only on my Saryn Prime config A) as of Angel of the Zariman hotfix #6. Is this only affecting people's most played frames?

 

yes, it only appear to affect my nezha prime, slot A

Link to comment
Share on other sites

So there is a temporary Fix, if anyone still need it.

Just make sure that you have no sigil on your conclave loadout, and just in case make sure that it's a different frame, then it should now work.

At least for me it finally worked.

Link to comment
Share on other sites

Hey everyone, thank you so much for the reports! 

This is an issue related to Conclave loadouts being read out as PVE loadouts, as Conclave loadouts can't equip Syndicate sigils - hence why they un-equip after leaving the Arsenal. We are working on a fix for this, it's proving to be slightly elusive but it is firmly on our radar. 

The temporary workaround is to set your Conclave loadout to a Frame configuration that you aren't currently using for PVE content, this will allow you to wear your Syndicate sigils without issue. This issue also affects the Ash Shroud Helmet, the same workaround applies and the eventual fix here should also fix that issue.

Thanks for your patience! 

 

  • Like 6
Link to comment
Share on other sites

8 minutes ago, [DE]Marcus said:

This is an issue related to Conclave loadouts being read out as PVE loadouts, as Conclave loadouts can't equip Syndicate sigils - hence why they un-equip after leaving the Arsenal. We are working on a fix for this, it's proving to be slightly elusive but it is firmly on our radar. 

The same issue applies on Excalibur Blade of the Lotus and Zato helmets, also on Ash Shroud since neither of these has been enabled in conclave despite being purely cosmetic items that have been in the game for a really long time.

Would it be possible to enable those helmets in conclave? That's the content i like the most in warframe and being unable to equip those helmets in there is the only thing holding me back from buying their bundles.

  • Like 2
Link to comment
Share on other sites

11 минут назад, ----Legacy---- сказал:

The same issue applies on Excalibur Blade of the Lotus and Zato helmets, also on Ash Shroud since neither of these has been enabled in conclave despite being purely cosmetic items that have been in the game for a really long time.

Would it be possible to enable those helmets in conclave? That's the content i like the most in warframe and being unable to equip those helmets in there is the only thing holding me back from buying their bundles.

isn't conclave on life support, basically? pretty sure it haven't seen support for new content for ages

Link to comment
Share on other sites

5 minutes ago, SilentMashiko said:

isn't conclave on life support, basically? pretty sure it haven't seen support for new content for ages

There is a playerbase, most of us play on private lobbies to avoid finding people who abuses gear that got bugged due to PvE changes bleeding over to PvP that DE then takes ages to address.

With that said, i guess its safe to say that players dedicated to conclave don't care about new content, it's all about having fun beating each other and getting better at the game while at it.

  • Like 3
Link to comment
Share on other sites

I can confirm that changing my conclave loadout to a different frame solved both the sigil issue and the Excal helmet issue for me. I can now equip sigils and any helmet to Excal Umbra, wheres before it would revert to no sigil and standard helmet as soon as I exited the Armory. Hopefully DE will find an actual fix soon so it doesn’t trouble anyone else. 

  • Like 3
Link to comment
Share on other sites

Same problem on all frames I have checked. Unless DE did this on purpose, it really needs to be fixed. No Syndicate progress means no Augment Mods, Relics, weapons or any other of the goodies that are the Reasons for joining a Syndicate. 

Link to comment
Share on other sites

Posted (edited)
On 2022-05-12 at 2:29 PM, [DE]Marcus said:

Hey everyone, thank you so much for the reports! 

This is an issue related to Conclave loadouts being read out as PVE loadouts, as Conclave loadouts can't equip Syndicate sigils - hence why they un-equip after leaving the Arsenal. We are working on a fix for this, it's proving to be slightly elusive but it is firmly on our radar. 

The temporary workaround is to set your Conclave loadout to a Frame configuration that you aren't currently using for PVE content, this will allow you to wear your Syndicate sigils without issue. This issue also affects the Ash Shroud Helmet, the same workaround applies and the eventual fix here should also fix that issue.

Thanks for your patience! 

 

Thanks for the update, Marcus! I am gonna attempt this fix right now. 

I don't understand why this works but TYVM Marcus! I am getting Syndicate credit again 😁

Edited by SpokesRS
Update
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...