Jump to content

Archived

This topic is now archived and is closed to further replies.

Regazozo

Credit Rewards and Credit Boosters Issues [Megathread]

Recommended Posts

Am i the only one who noticed no credits from sorties too i thinmk they want us to buy credit packs lol.

Share this post


Link to post
Share on other sites
2 hours ago, KingNoobsta said:

all credits are now 50% low. I dnt expect 40-50k per 2 mins. 

 

just dug and heres what I got : 14400. So anyone still saying 40-50k  ??

 

52edf66711c542659597c5eee1c4ed42.png

DE be like "Oh hey guys, we see you complain a lot for credit nerfs, no problem, we got you fam." 

Price Revisions:

  • Frugal Credits Bundle: 50k Credits for 50 Platinum.
  • High Roller Credit Bundle: 175k Credits for 90 Platinum.

And some people say this is a bug with credit rewards, I just laugh my &#! off.

Share this post


Link to post
Share on other sites

No credit bonus per extractor either, its always 14400 now it seems.

First time I ran it after the patch I got around 30000 so not sure whats going on.

Share this post


Link to post
Share on other sites
6 hours ago, DerMetzgermeister said:

Well wish I had known of this bug before. Just spent the past hour completing today's Sortie with a credit booster, got nada.

credit booster neither works

Share this post


Link to post
Share on other sites
7 hours ago, Halp said:

 

 

please stop saying this. its not true. you get 14k  from the high level dark sectors now, 28k with a  booster maxing out at 32k with a 5k cache.

 

AkzrCxC.jpg?1

k62Nlc1.jpg?1

nsCBtUt.jpg?1

 

you and everyone else that has millions and hasn't had to do a credit farm in forever need to actually play the missions.

 

You and everyone else cant count or actually remember how many credits they have... Check your credits before and after the mission.

Its a visual bug. It still gives 40-50K with a booster.
I actually farm there daily. 

Share this post


Link to post
Share on other sites

 At the moment Zorro. The sorties are giving no credits at all apart from what you pick up so they have nothing in them to double for you. I dont whether its a nerf or a bug. Abuela is there any way you can confirm that the visual bug applies to the affinity as well. I have a 3 day ready to activate but im worried if I do it wont work.,

Thanks 

Share this post


Link to post
Share on other sites

I have just spent several hours running dark sectors and have noticed extremely low credit rewards... am I right in this or is this a bug? and I am using all available buster including credit boosters

Share this post


Link to post
Share on other sites

So basicly baro will hit us in few days and I myself and a lot of other tenno's will be out of credits to purchase items off him. It kinda saddens me, day 3 of the patch, yet no single patch/hotfix. Brace ourselves guys, dark times has fallen over warframe. :( Lets hope i'm not right and we will see the light b4 hes upon us.

Share this post


Link to post
Share on other sites
11 minutes ago, -HitZ- said:

So basicly baro will hit us in few days and I myself and a lot of other tenno's will be out of credits to purchase items off him. It kinda saddens me, day 3 of the patch, yet no single patch/hotfix. Brace ourselves guys, dark times has fallen over warframe. :( Lets hope i'm not right and we will see the light b4 hes upon us.

Did you read ? get a booster and do Hieracon you get 40-50K in 2-3 minutes... Stop crying for credits they are easy to farm.

P.S. you have 5-7 days... its enough time.

 

Share this post


Link to post
Share on other sites

I haven't tested it myself but it does seem to be something people are posting a lot about. Can you check your actual credit amount before and after a mission? I'm wondering if it's a display issue (i.e. actual received amount in mission rewards not displaying correctly) or if the boosters aren't working at all.

Share this post


Link to post
Share on other sites
7 minutes ago, CouncilCat said:

Did you read ? get a booster and do Hieracon you get 40-50K in 2-3 minutes... Stop crying for credits they are easy to farm.

 

I did hieracon, 1 excavator then out, no booster 14k credits, I dont know whos your dealer and from where you are pulling those numbers. Boosters are broken at the moment and not working(as some people told you already), even tho with booster, the credits would have been 28k, not 50k. Also would kindly ask you to not pollute my topic, we understood that you are biased fanboi.

Share this post


Link to post
Share on other sites

none of my clan mates booster work since the update and we all made an support ticket yesterday.

Share this post


Link to post
Share on other sites

My friends and I are having the same issue. I have a 7 day credit booster and I am not getting any boost at all.

 

Share this post


Link to post
Share on other sites
1 minute ago, -HitZ- said:

I did hieracon, 1 excavator then out, no booster 14k credits, I dont know whos your dealer and from where you are pulling those numbers. Boosters are broken at the moment and not working(as some people told you already), even tho with booster, the credits would have been 28k, not 50k. Also would kindly ask you to not pollute my topic, we understood that you are biased fanboi.

You obviously didn't read anything I said. I'm not doing anything wrong... you are. I said like 5 times that its a visual bug.

I have a booster on and I'm getting 50K credits a run with 1 excavator on Hieracon.

Yes the mission is saying 14K and such but have you checked your credits total before and after the mission ? Obviously not.

Its just a bug. I'm still getting the correct amount of credits. 

Try not to be ignorant with other comments and say that someone is "pullute" if you didn't even read the comment properly. 

All you are doing is acting like a drama queen. Its a new patch and there are bugs here and there. Try to find and solution to them not cry left and right ( and maybe actually read what others have to say ).

And no need to be rude just because you don't agree with my opinion and insult me for no reason.

Share this post


Link to post
Share on other sites
1 minute ago, CouncilCat said:

You obviously didn't read anything I said. I'm not doing anything wrong... you are. I said like 5 times that its a visual bug.

I have a booster on and I'm getting 50K credits a run with 1 excavator on Hieracon.

Yes the mission is saying 14K and such but have you checked your credits total before and after the mission ? Obviously not.

Its just a bug. I'm still getting the correct amount of credits. 

Try not to be ignorant with other comments and say that someone is "pullute" if you didn't even read the comment properly. 

All you are doing is acting like a drama queen. Its a new patch and there are bugs here and there. Try to find and solution to them not cry left and right ( and maybe actually read what others have to say ).

And no need to be rude just because you don't agree with my opinion and insult me for no reason.

First, don't make me repeat myself, I went straight away and tested it, went with 50k credits balance in the mission, completed it and i got awareded with 14k credits and excavator reward of 5k. When I got out I was with 70k credits balance. How that makes it visual bug(simple math), pls explain? As for the boosters people said that they are bugged, I'm not wasting plat just to see if they are working. Also, if voicing my concerns about the game, because I truly care is deemed as crying or being drama queen I don't know what to call you for defending clearly flawed system. Probably will be euphemism.

Share this post


Link to post
Share on other sites

my 2x credit and exp i paid for 90days is not working and has not since the update im unhappy. i would seek a refund i have like 82 days left.

 

Share this post


Link to post
Share on other sites
Just now, -HitZ- said:

First, don't make me repeat myself, I went straight away and tested it, went with 50k credits balance in the mission, completed it and i got awareded with 14k credits and excavator reward of 5k. When I got out I was with 70k credits balance. How that makes it visual bug(simple math), pls explain? As for the boosters people said that they are bugged, I'm not wasting plat just to see if they are working. Also, if voicing my concerns about the game, because I truly care is deemed as crying or being drama queen I don't know what to call you for defending clearly flawed system. Probably will be euphemism.

I really don't think you really care about anyone but yourself since you cant "waste" 40 plat to support and help this problem get fixed.

You just "truly care" about yourself. If it was bugged in your favor you would have no complain.

And I just retested it 5 times. 

We are both correct for some odd reason.

I got 2 times 50K 1 time 40k and 2 times 30K. 

I have no idea what is influencing this to happen. 

I will keep this updated.

Share this post


Link to post
Share on other sites
48 minutes ago, Letter13 said:

I haven't tested it myself but it does seem to be something people are posting a lot about. Can you check your actual credit amount before and after a mission? I'm wondering if it's a display issue (i.e. actual received amount in mission rewards not displaying correctly) or if the boosters aren't working at all.

It happens to many people , inculding me when i got from Login Reward , but killing an infested [ example ] , it should drop 200-300 Nano Spore if you have booster on but instead , it only drop 100-150 . 

Share this post


Link to post
Share on other sites

So Hieracon and most endless Dark Sectors yield the most credits now?

Share this post


Link to post
Share on other sites
Just now, Taedber said:

So Hieracon and most endless Dark Sectors yield the most credits now?

Basically yes... But its really buggy atm. So do Hieracon 1-2 extractors and leave is most efficient right now.

 Unless you find a 4 man team and rush Raids. 

Raids might become the next credit farm unfortunately.

And that might be a problem for new players.

Share this post


Link to post
Share on other sites

×
×
  • Create New...