[DE]Glen

W10 Creators Update and Mouse Buttons

Recommended Posts

Please, Is there any chance of getting a fix for this anytime soon?  I'm tired of having to disable my laptop's touchscreen and trackpad, and then having to reboot, in order to play the game The way I've played it since Beta. 

Thanks

Share this post


Link to post
Share on other sites

For the past 3-4 months, Warframe stopped registering the side-buttons for the thumb on my mouse. It used to work, and I've been hoping it would have been fixed in a hotfix to re-enable it. Now before anyone says "You're mouse is broken" it works just fine on every other application. I can use Mouse 4 and 5 for other games as well as going back and forward 1 page on web browsers, so it's something specifically wrong with Warframe. I am running Windows 10 64bit and my mouse is a Mionix Castor.
Please fix this so I can get back to using my alternate fire modes for my guns, thanks! :cool:
 Forgot to mention that after an update to Warframe the buttons no longer registered. But it may be possible a windows 10 update is responsible, but that wouldn't explain why only Warframe no longer registers these buttons.
Edit: This seems to only be a problem on Windows 10 with the Creators Update. Thank you , Ceryk, for pointing this out.

 

Edited by SuperPancakes

Share this post


Link to post
Share on other sites

mine worked up until a few days ago, but now when i press my buttons for changing my DPS on the fly as it's supposed to, i now crouch when i push them.

 

edit: it's not windows 10 i don't think since i've been using it since december and this mouse has worked fine up until a few days...it's a logitech g502 i got a couple months ago.

Edited by Magicfingers
added some stuff

Share this post


Link to post
Share on other sites
8 minutes ago, Magicfingers said:

mine worked up until a few days ago, but now when i press my buttons for changing my DPS on the fly as it's supposed to, i now crouch when i push them.

 

edit: it's not windows 10 i don't think since i've been using it since december and this mouse has worked fine up until a few days...it's a logitech g502 i got a couple months ago.

Check the Logitech software to see what your buttons are set to do and if its using a dedicated profile for Warframe.
I have a Logitech G600 and all 15 of my buttons still work.

Share this post


Link to post
Share on other sites

There is a known issue with Windows 10 Creators Edition and Mouse Buttons... If you are using Creators Edition, that could very well be the issue. If you aren't using Creators Edition, hard to tell what it is. I'd check the mouse program's settings (assuming they have one, I'm a Razer user, so dunno about Logitec gear) and see if anything is funky there.

Edited by Ceryk

Share this post


Link to post
Share on other sites
1 minute ago, Ceryk said:

There is a known issue with Windows 10 Creators Edition and Mouse Buttons... If you are using Creators Edition, that could very well be the issue. If you aren't using that, hard to tell what it is.

I'm on Windows 10 Pro, but is there a solution yet for Creators Edition? It might work for Pro aswell if there is.

Share this post


Link to post
Share on other sites
6 minutes ago, SuperPancakes said:

I'm on Windows 10 Pro, but is there a solution yet for Creators Edition? It might work for Pro aswell if there is.

Sorry, I misworded it as Edition and meant Update -_- My brain is kind of dead after the horribly boring class I was just in. Creators is the next major update for Windows 10 rather than a separate version like Home or Pro. It's currently opt-in since it's not officially live yet. If you didn't specifically go into the Update Center and choose to download it, you probably aren't running it. Though if you are sharing a computer with anyone, I'd consider checking and seeing if you are running the Creator Update...

Edited by Ceryk

Share this post


Link to post
Share on other sites

Weird. I am the only person that uses my PC and it seems to have installed Creators Update on it's own. That would explain things. It doesn't explain why it only effects Warframe, though. Regardless, a fix for this would be helpful.

EDIT: Just found the thread [DE]Glen posted about this very issue and many solutions are posted there

 

Edited by SuperPancakes

Share this post


Link to post
Share on other sites
1 hour ago, Keiiken said:

Check the Logitech software to see what your buttons are set to do and if its using a dedicated profile for Warframe.
I have a Logitech G600 and all 15 of my buttons still work.

first thing i thought of. checked and made sure it was configured right (it was), checked the button assignments in warframe (everything was set as it should be). some of my buttons just don't work in warframe the way they should. btw, i'm using window 10. but not the creators version.

Share this post


Link to post
Share on other sites

I having the same problem, worked fine as of the last hotfix, mouse buttons work fine outside WF.  I might also note that I lost my melee block mb2 about a year ago.

Defaulting does not work, and if I log on from my other machine it's a global problem.  Both machines same missing abilities lost in key binding.

Share this post


Link to post
Share on other sites

Hi everyone, i solved the problem (for me at least) so here's what i did:

-opened device manager

-mice and other pointing devices

-uninstalled my mouse

-unplug and plug it again

now windows recognize all my 5 buttons :D

Share this post


Link to post
Share on other sites

Still have this issue sadly. Did a fresh install of windows with my new setup and the buttons still aren't working just in warframe. It works in everything else as it should and I don't feel like getting an external program just for the fix sadly. :/

 

Edit: Never mind. The issue was fixed from what someone else suggested, disabling all the HID mouse under the device manager besides the one that disables the mouse.

 Lo8bLCI.png

What mine looks like^

Edited by Dini

Share this post


Link to post
Share on other sites

The workaround that helped me was disabling my Razer keyboard's virtual mouse function via the Windows Device Manager. Please note that I needed to relaunch the test application for it to detect the changes.

Both my Logitech Gaming G700s mouse and my Razer Deathstalker keyboard utilize virtual mice and keyboards for macro functions, hence the many virtual, generically named devices.

Before disabling
b59e0ac9ca0216cea2b5f6af693fb820.png

After Disabling and relaunching the application:
969ec2b4fdde96d02ee88355e2bc354f.png

Share this post


Link to post
Share on other sites

Fixed my mouse having the problem by turning off fast boot but also by updating all my drivers to their most recent update using driver booster from iobit.

 

Share this post


Link to post
Share on other sites

Back to being broken here again, dammit. This is ridiculous that MS has let this go on this long :\

Share this post


Link to post
Share on other sites
On 17/07/2017 at 7:17 PM, Keiiken said:

Check the Logitech software to see what your buttons are set to do and if its using a dedicated profile for Warframe.
I have a Logitech G600 and all 15 of my buttons still work.

If using a 502 this is the answer. I recently had the same issue as Magicfingers and it was because the profile wasn't working. I had to re-point the Logitech profile to the game executable to fix it.

Share this post


Link to post
Share on other sites

So I had the issue with Deathadder Chroma and with touchpad drivers too that after Win10 update both weren't working properly.
For touchpad I needed to download the exact driver to repair it then delete (the repaied one) only after that I was able to install the newest driver.
My Chroma mouse seemed fine because it saved my lightning settings but the extra 2 buttons nor the software didn't work at all. Needed to delete then install the new drivers.

So if anybody noticed it after Win10 update I suggest looking for a newer driver and figure a way to update them.

Share this post


Link to post
Share on other sites
On 09/08/2017 at 0:59 AM, VoidsShadow said:

The workaround that helped me was disabling my Razer keyboard's virtual mouse function via the Windows Device Manager. Please note that I needed to relaunch the test application for it to detect the changes.

Both my Logitech Gaming G700s mouse and my Razer Deathstalker keyboard utilize virtual mice and keyboards for macro functions, hence the many virtual, generically named devices.

 

I am having this problem and this solution worked for me. I'm using a Nixeus Revel mouse and a Razer Blackwidow tournament edition. Reinstalling my drivers did not work for me.

In my device manager, under "Mice and other pointing devices" there were three devices called "HID-compliant mouse". I disabled the two of them that weren't the actual mouse and now I can bind mouse4 and mouse5.

Still annoying as I suspect this will have some undesired affects such as disabling some macro features, so it would be cool if you guys had an actual fix. My mouse4 and mouse5 works fine for other games like Guild Wars 2.

Share this post


Link to post
Share on other sites

In my case disabling and re-enabling all devices except my actual mouse under "Mice and other pointding devices" in Windows Device Manager solves the problem (until I reboot the PC).

Here's my automated workaround (requires administrator privileges).

USE AT YOUR OWN RISK!

I've created a simple PowerShell script which enumerates connected mouse class devices then disables and enables all of them except the actual mouse with thumb buttons.

Step 1

Start PowerShell and run the following command:

Spoiler

gwmi -Query "SELECT Name from Win32_PnPEntity WHERE PNPClass = 'Mouse'" | ft Name

It'll list all mouse class devices connected to your system.

Find the name of the mouse having issues with thumb buttons (Razer Taipan in my case).

Step 2

Start Notepad and paste the following code:

Spoiler

$mouse_to_fix = 'My mouse'
$hid_mice = gwmi -Query "SELECT * from Win32_PnPEntity WHERE PNPClass = 'Mouse' AND Name != '$mouse_to_fix'"
foreach ($mouse in $hid_mice) {
$mouse.Disable()
}
foreach ($mouse in $hid_mice) {
$mouse.Enable()
}

Change My mouse in the 1st line to your mouse name from Step 1

e.g.

Spoiler

$mouse_to_fix = 'Razer Taipan'

Save the file with .ps1 extension e.g. C:\MouseFix.ps1 (saving the file in C:\ directory will require Notepad to be started as Administrator)

Step 3a (Run the script manually)

Start PowerShell as Administrator and run C:\MouseFix.ps1

or

Step 3b (If you want the script to run every time you boot your PC)

Create a scheduled task using following command:

Spoiler

schtasks.exe /Create /TN "Mouse Fix" /TR "%SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe -windowstyle hidden "C:\MouseFix.ps1"" /SC ONLOGON /RL HIGHEST

Then run the "Mouse Fix" scheduled task:

Spoiler

schtasks.exe /Run /TN "Mouse Fix"

Step 4

Grofit!

Edited by Melchiah
No reason

Share this post


Link to post
Share on other sites

I can confirm that disabling in "device manager options'' ''HID-compliant mouse'' solves the problem at mise and other pointing devices.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now