Jump to content
Dante Unbound: Known Issues ×
Dante Unbound: Share Bug Reports and Feedback Here! ×

Railjack Revisited (Part 1): Bug Report Megathread (Read First Post!)


Recommended Posts

  • TYPE: Mission results
  • DESCRIPTION: Piloted the Railjack in Operator form in Flexa and Ganalen's Grave (sentient fortress). Got awarded with 8 levels of Amp affinity, yet only 1 intrinsic point for the 2 missions, which I expect came from scouring the sentient fortress as Garuda.
  • REPRODUCTION: Pilot the Railjack in Operator form.
  • EXPECTED RESULT: Piloting the Railjack in Operator form awards intrinsics points normally.
  • OBSERVED RESULT: Piloting the Railjack in Operator form doesn't award intrinsics points.
Link to comment
Share on other sites

TYPE:Weapon modding/Riven

Description:For some weird reason my dual cleaver riven have different stat in the mods segment and in the arsenal segment


Reproduction:I leveled up my riven by using my arsenal segment and i found this bug

Expected result:The riven stat must be the same in the modding segment and in the arsenal segment

Observed result :The riven have higher stat in the modding segment and lower stat in the arsenal segment

Reproduction rate:Not sure about this one,it happens to me and i feel like it was a bug.

Link to comment
Share on other sites


Description:Sometime when using Revenant 3rd ability while channeling its 4th ability,im stuck with his 4th ability phase not being able to do anything except moving.


Reproduction:Use Revenant 3rd ability with its 4th ability active

Expected result:Should be able to canceled out its 4th ability and use 3rd ability to move

Observed result:Stuck in Revenant channeling unable to do anyhing beside moving

Reproduction rate:Happen to me frequently when doing short / non-endless mission run

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: The Gokstad Crewships in Empyrean do not let me fire their weapons, no matter what - which makes it very hard to complete a nightwave that asks me to fire weapons.
  • VISUAL: none, though there's not much to show I don't think?
  • REPRODUCTION: in theory It has always been this way for me ever since it came out. I thought it was normal and I misunderstood what hijacking enemy crewships let you do.
  • EXPECTED RESULT: I expected to shoot missiles or a gun or something, or see stats for one
  • OBSERVED RESULT: nothing happens! and according to others it's as simple as shooting any other gun like on a frame or your rail jack. nothing happens, _ever_. I tried leaving the gunner alive, I tried the gunner seat and the pilot seat, Nothing ever lets me fire the missiles on the crew ship.
  • REPRODUCTION RATE: I at least have a perfect reproduction rate because it has always been that way when I try it on any day since start.
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Using railjack navigation panel to enter dojo freezes game. Mission rewards are saved.
  • VISUALhttps://imgur.com/gallery/HSJI4hB
  • REPRODUCTION: Complete all mission objectives in railjack node, collect floating loot from destroyed enemies, select dojo from railjack navigation panel.
  • EXPECTED RESULT: Railjack travels to dojo without problems.
  • OBSERVED RESULT: Game freezes, takes roughly 2 minutes to become responsive again..
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Railjack drift doesn't work, and intermittently archwing dash doesn't work during Railjack missions
  • VISUAL: n/a
  • REPRODUCTION: Every Railjack mission for me currently
  • EXPECTED RESULT: Railjack drift maneuver works normally, archwing dash works normally
  • OBSERVED RESULT: Double-tap of shift key doesn't initiate drift maneuver or dash, just results in normal boost or sprint


  • NOTE: I have played a lot of Railjack and I know how this is supposed to function. I've been unable to use drift since sometime after Scarlet Spear ended, probably around the time of not the very last double-affinity weekend but the one previous to that. I mention it because I reached rank 10 in all Intrinsics around that time and the issue seems to have come up around the time I capped my last intrinsic (I ranked Piloting to 10 last).

    To remedy the issue I've tried resetting my controls to defaults, unequipping all of my avionics (and re-equipping them) and re-equipping my starter Sigma engines. None of these corrected the issue. As an added bonus, my dash/blink in archwing intermittently stops working during Railjack missions as well, though it's not as consistent as the loss of drifting. Wondering if it could be related since it's a similar key press. The archwing issue does not come up in open world or during normal archwing missions.


  • EDIT: Additional note, my Cruising Speed avionic also no longer seems to engage so it could be related though as I mentioned, this issue is 100% reproducible for me either with or without any and/or all of my normal avionics.


  • EDIT2: I figured it out; there's a 'Boost/Maneuver' control setting that's separate from the simple 'Boost' control setting. I had the latter assigned but not the former, and when I switched to 'defaults' it flipped them. This must have gotten switched around during an update or something because I definitely wasn't fiddling around in there.

    I should/could have looked more carefully through the control setting groups to find the separate Railjack controls, as I apparently only reset my regular controls to defaults in the first place.

Link to comment
Share on other sites

Type: Ingame

Description: My doggo grew to enormous proportions.

Visual: Skjermbilde_19.png

Reproduction: Happens everytime I enter the railjack with my helmith equiped.

Expected result: I expect it to remain at the same size.

Observed result: Doggo grows so big that you can't see when piloting.

Reproduction rate: 100%

Edit: Seems to only occur on most of earths nodes

Link to comment
Share on other sites

  • TYPE: In-game
  • DESCRIPTION: The game won't allow any other input except moving with wasd while invisible with operator's glasses barely visible while in railjack's space.
  • VISUAL: rage quitted forgot to take picture
  • REPRODUCTION: Being in operator invis mode while the enemy's crewship is exploding
  • EXPECTED RESULT: Supposed to die or something
  • OBSERVED RESULT: See description
  • REPRODUCTION RATE: Quite often, but not 100%
Link to comment
Share on other sites

  • 4 weeks later...

Hey DE Bear, if we are helping to squash bugs you might need to get a bigger mallet for the soul who has to deal with this one. 

  • TYPE: PC wreckage scrap window. 
  • DESCRIPTION: Attempting to scrap Rail jack wreckage. 
  • VISUAL: unknown.png
  • REPRODUCTION: Find some way outside of a Clan to open said window (Really need a button to enter the scrap wreckage menu outside of Drydock). I click on any node in the Proxima Starchart.  
  • EXPECTED RESULT: Would expect a the scrap button to work to allow me to scrap stuff out to continue to play some rail jack missions. 
  • OBSERVED RESULT: Button is grayed out and not scrapping single or multiple parts. 
  • REPRODUCTION RATE: Constant and I can make the problem worse by adding more parts bypassing the cap consistently, see below 
  • HOW I GOT HERE: Oh boy, so in update 28.0 the addition of the join any crew button was added, I started using this to join rail jack missions as it was a great quality of life improvement. On the checking each node I was able to scrap parts if I was over the limit before I joined a crew. For some reason this scraping system was working great until update 28.0.5. At this point and time the scrap button in the scrap menu went dead. Now to the point of how my inventory has swelled beyond the cap, using the join any crew button it launches me right into a node without checking if I am above the scrap limit. I sitting at 60+ chunks of Rail jack wreckage at time of writing and a bit concerned, I want to scrap them but the above picture is my current state of affairs with the problem. At the end of each mission it sends me back to my orbiter because it realizes I am above the wreckage limit, with the loot and more wreckage.  
    1. Do not be in a clan and do not own a Rail jack
    2. Use Join Any Crew on any Proxima 
    3. Run until cap is reached, then exceed it.
    4. Attempt to click on scrap button to turn wreckage into blue and black crystal punch card boxes (The name of the items escapes me).
    5. Go to Forums in panic. 

Anyway I hope this brings this lovely little bug to light and I really enjoy the mechanics around rail jack, I have some quibbles but over all its a neat game mode. 

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

probably to late for people to see this but

  • TYPE: ingame
  • DESCRIPTION: the war within quest line crashes when ordis starts to talk after trying to re-energize the transference pod (chair) after teshin knocks the operator out of the transference chair
  • VISUAL: https://www.youtube.com/watch?v=JUU0xufAxLQ
  • REPRODUCTION: play the war within, and shoot the transference chair when it asks you too. so far it has occured 100% of the time when i tried it
  • EXPECTED RESULT: ordis continues talking and we get on with the mission
  • OBSERVED RESULT: game freezes when ordis says " but how will you control the war frames"
  • additional comment: being that the war within is a quest that locks you into the mission, and prevents you from exiting this quest, i am now prevented from doing anything else in warframe but replicate this bug, its quite a serious bug and is in fact very game breaking. i would hope this bug is addresses asap because i literally cant play warframe anymore.
Link to comment
Share on other sites

On 2020-05-09 at 3:50 AM, 0x62 said:
  • TYPE: In Game
  • DESCRIPTION: Tac 10 teleport and Slingshot don't mix
  • VISUAL: End result: https://gyazo.com/72ba83ea62715bc51a03df82a353cfbb
  • REPRODUCTION: Slingshot to somewhere. While doing so, Tac 10 teleport (destination can be on land or archwing)
  • EXPECTED RESULT: Tac 10 should override the player's indecision, canceling the slingshot and properly finishing the warp.
  • OBSERVED RESULT: Player is locked in place, unable to do anything, continuously sliding forward.

Revisiting Warframe after 3 months, and this specific bug still exists without any sign of being ingested by the dev team (to either rank low on priority of fixing, or high on priority). How do we know that bugs are seen (as I am going through previous bugs I have reported on, and the bugs haven't been fixed yet)?

Link to comment
Share on other sites

  • 5 weeks later...

TYPE: In-Game

DESCRIPTION: When I enter most if not all seats (gunner, pilot, crewship pilot, forward artillery) I am not able to leave it by pressing the interact button. The only way to leave the seat is to open the tactical menu and teleport somewhere within the railjack. In cases where this is not possible (ie crewships) this is not possible (in the case of crewships specifically, someone has to destroy the crewship in order to free me). Forcing a gunner seat leave often results in a visual bug where the arm mounts remain mounted on your warframe for the rest of the match.

REPRODUCTION: Change key binding and try to use it to exit any occupiable railjack seat, changing the interact key back to "x" fixes the issue 

EXPECTED RESULT: I should leave the seat on pressing interact button (e)

OBSERVED RESULT: Nothing happens, no sound, no visual change, no functional change.

REPRODUCTION RATE: 100%, every time without fail

Link to comment
Share on other sites

  • 1 month later...
On 2020-04-30 at 8:51 AM, [DE]Bear said:

Greetings, Bug-Squashing Tenno!

With the release of Railjack Revisited (Part 1), we have been working hard to tackle as many bugs as possible. That is not to say that some may slip through the cracks. If you do encounter a bug, please use this thread to report it so we can address it ASAP!

Notable changes with Railjack Revisited (Part 1):

  • Increased item vacuum and base speed on Railjacks
  • Weapon, Avionic, and Railjack statistics have changed
  • Enemy damage values have changed
  • Enemy Health values have changed
  • Healing Abilities now affect objects (like Defense Targets)
  • Other fixes and Quality of Life changes

For a full list of changes in Warframe Revised: Railjack Revisited (Part 1), you can read the Update Notes by clicking on this link.


  • Include a video or a screenshot if possible! Visual references can help direct us to issues faster than without them.
  • Steps to recreate the bug, if known. Again, this is to help us locate the issue faster.
  • If you saw the Warframe Crash Handler and got a WAR number  (looks like this: WAR-1234567) then add it to your post.  Also please be sure to be as descriptive as possible in the Crash Handler's comment box!


  • TYPE: [Launcher, In-Game, Chat, etc.]
  • DESCRIPTION: [Tell us what you were doing when the bug occurred. Details here are helpful]
  • VISUAL: [This is where you would add your screenshot or video]
  • REPRODUCTION: [Tell us how we can replicate this bug, if known]
  • EXPECTED RESULT: [Tell us what you think should have happened, ex: “I should have drawn my weapon”]
  • OBSERVED RESULT: [What actually happened, ex: “I went into a T-Pose”]
  • REPRODUCTION RATE: [How often it happens when you try to reproduce it, ex: “It only happens half the time / when I am crouching / when using Hydroid.”]

Using the format above helps us identify issues, hunt down the cause, and fix problems faster than telling us “this thing is broken”. As with all cases, please make sure your bug reports are constructive and civil, and we want to thank you for your patience as we work on fixes.



I don't know if you're aware, but ever since the Deimos update, you can't see the player list and their stations (indicated by an icon) in the upper right part of the screen anymore whenever you're engaged in a ship station. This means that when you're a pilot, or in the arty, or in a side gun, you can't see the player list, where people are, or even who's on your ship unless you hit "L" and look at the tactical menu. As a pilot, this is hugely inconvenient. Once I start a mission and am flying around, I can't even tell who's on my ship, if I'm alone, or if people have randomly joined me unless I check the L menu or unless I see a mystery crewman start firing at stuff. It's there if you're just running around on the ship, but if you jump into the pilot's seat, it disappears. Please return the player list to the top-right when engaged with stations.


Link to comment
Share on other sites

  • 4 months later...

Type: Foundy/Account
Description: Trying to Claim Bonewidow Necramech from foundry.

Reproduction: Unknown
Expected Result: Bonewidow would be added to it's respective inventory slot and able to be used
Observed Report: Error saying that I have invalid inventory slots. (I only have the Voidrig necramech and 3 open slots)
Reproduction Rate: Every time I try to claim Bonewidow from the foundry

Link to comment
Share on other sites

  • TYPE: In-game ( Mission Crew AI)
  • DESCRIPTION: I was on Venus Proxima doing the mission Bifrost Echo. When sitting still the enemy would spawn in and my ai crew would have no issues taking them out. Upon entering one of the floating towers to do a on foot mission, I noticed my railjack started to take damage. Upon getting to the end of the tower the exit let you see into space. This is when I would see my railjack being attacked by enemy ships, however my gunners would not be shooting back. Even after going back into space from the end area exit point the ai of my ship would still not shoot. Only after I got back on board the railjack did my crew assigned to the gunners start to fire on the enemy ships. I did notice a difference between boarding the tower and boarding the corpus ship that my railjack had it's health bar go grey and became invincble during the corpus ship part. This did not happen during the tower boarding though, no clue if this might be the issue for the problem.
  • EDIT: This seems to happen with any of the missions you can enter the tower structures floating in space not just the one I listed.

















  • REPRODUCTION: Upon entering the mission for Bifrost Echo head to the white objective marker that is show on a tower. Enemies should start spawning nearby. Upon entering the tower the ai stops using the gun turrets and the railjack will start taking damage from the enemy controlled ships. When you exit the tower back into space the ai will still be broken. Only once you board the railjack will the ai begin to shoot as they did before.
  • EXPECTED RESULT: My ai crew mates should not have had their ai stop working during this time. Possibly the railjack should of had the grey hp bar like it did during the on foot corpus ship portion of this mission as well.
  • OBSERVED RESULT: My crew ai stopped working as they should have, resulting in the railjack taking damage over time and getting multiple "Catastrophic failure" messages throughout the on foot portion about my railjack blowing up if I did not return and fix it. This was due to the ai not using the gun turrets as they should of even though they had been assigned to them and are shown to be manning them in the screenshots above.
  • REPRODUCTION RATE: I have only tried this mission twice so far, and have been able to replicate it each time I have done it.
Link to comment
Share on other sites

  • TYPE: In-game, in-mission, Railjack
  • DESCRIPTION: Completed Railjack: Arc Silver Defense mission portion. Chose to extract after successfully completing 5 waves. Was teleported back to Railjack and was told by Cy that the mission was a failure. Unable to interact with remaining Derelict and unable to go to next node. No end mission rewards given.
  • EXPECTED RESULT: I should have successfully completed the entire Arc Silver mission after successfully completing the Defense portion.
  • OBSERVED RESULT: Mission failed after choosing to extract after 5 waves.
  • REPRODUCTION RATE: Only tried once.
Link to comment
Share on other sites

  • TYPE: In-Game (Mission)
  • DESCRIPTION: Upon completing a railjack mission there is no way to return from the mission if you are not in a clan. When completing a mission the only choices you can make are to either keep doing missions or abort if you want to leave. As of now there is no option to return to the public drydock or your orbiter. This means it is almost impossible to progress in the game as when you abandon the mission you retain items, but not the affinity.
  • REPRODUCTION: Complete any railjack mission as the host without being in a clan.
  • EXPECTED RESULT: There should be some way to return to either the public drydock or your orbiter without abandoning the mission.
  • OBSERVED RESULT: Only option after a railjack mission is complete is aborting the mission or going to a new railjack mission.
  • REPRODUCTION RATE: Every single time I do a mission.

Edit: Not a bug. The relay drydocks are on the planets, not the giant thing that says drydock in the railjack mission.

Link to comment
Share on other sites

  • TYPE: In-game, in-mission, Railjack
  • DESCRIPTION: Frame ability kills don't give Plexus affinity after recent hotfix. I assume they did before, as I leveled it once to 30 already using Khora and noticed that I barely got any exp in last few missions.



  • REPRODUCTION: Also tried on Saryn for the same result. Weapon kills give affinity, frame abilities don't.
  • EXPECTED RESULT: Ability kills grant Plexus afiinity
  • OBSERVED RESULT: They don't 😉
  • REPRODUCTION RATE: 100% for me.
Link to comment
Share on other sites

TYPE: In-Game, Orbiter 
DESCRIPTION: So I was attempting to find my Plexus, since I completed the archwing quest several weeks ago and should have received one. I was told it should be to the left of the navigation console. I approached those consoles, and no interaction option appeared. 

REPRODUCTION: Not sure how you would replicate this? 
EXPECTED RESULT: My expectation was that I would be able to interact with the Plexus from one of these consoles. 
OBSERVED RESULT: No interaction option is coming up at all on either of these consoles. (I will not that all the other consoles are working as normal. 
REPRODUCTION RATE: It has been pretty constant throughout several log-ins and log-outs. 

Link to comment
Share on other sites

  • 3 weeks later...
  • TYPE: In-Game
  • DESCRIPTION: In the middle of Kasio's Rest, after repelling borders, midway through exposing reactors. 
  • VISUAL: https://drive.google.com/file/d/1DAmZhadmn7gTUqv97w_NzYjvojd_3cEs/view?usp=sharing
  • EXPECTED RESULT: Normal railjack gameplay
  • OBSERVED RESULT: Total physics breakdown: invisible walls, exit railjack (no archwing, drop until death, or land on exterior again no archwing), not being able to move railjack, failed to render half the skybox, archwing slingshot teleports player to invisible space outside artillery station
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...