Jump to content
[DE]Megan

Octavia’s Anthem: Hotfix 20.0.2

Recommended Posts

Just now, Lorellya said:

FIX THE BLOODY HUD! I'm not giving DE a single coin until they fix this!

Lol like they don't hear that every hour. xD Patience my friend it is Friday night, got all night to do this.

  • Upvote 1

Share this post


Link to post
Share on other sites

............................And cant login again, second hotfix later -_- network not responding.
Well seems I'll be staring at the wall until this gets fixed.

Share this post


Link to post
Share on other sites
Just now, ComCray said:

can't login? systems said check login info??

Yeah was really looking forward to checking this update out. Went to dojo to start building the altar and got interrupted by a hot fix....can't log in at all now.

Share this post


Link to post
Share on other sites

!!Network Problems!! no problemoo my tenno friends just go get somee ....................................... sorry  Network  no response  pls try again leter

hqdefault.jpg

  • Upvote 3

Share this post


Link to post
Share on other sites
1 minute ago, Emecay said:

This hotfix has left me "trapped" in an endless relic selection, which I'm worried about leaving due to item loss.  

last hotfix turned my dojo into the Hotel California, every time I left I ended up in a different area.

 

  • Upvote 2

Share this post


Link to post
Share on other sites
2 minutes ago, Tokyopig said:

............................And cant login again, second hotfix later -_- network not responding.
Well seems I'll be staring at the wall until this gets fixed.

Considering how awful the "quest" is (aside maybe from interraction with Ordis) or that you once again need to farm every piece of warframe separetely after getting the bp from the quest you're not missing much anyway.

  • Upvote 2

Share this post


Link to post
Share on other sites
1 minute ago, Atylia said:

I don't mind these problems....as long as DE has compensation :^)

Maybe a reset on that afinity booster they gave us...

Share this post


Link to post
Share on other sites

Big, low resolution HUD right now. RIP. Took 10 minutes to get back on servers, got a "Network Not Responding", then the HUD was huge. AHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH. Update #4?

  • Upvote 4

Share this post


Link to post
Share on other sites

So I did the quest but I didn't get the parts, is this supposed to happen or is it a bug? I did get the blueprint tho

Share this post


Link to post
Share on other sites

FIX THE HUD, ITS SUPER ANNOYING !!!!!!!! LIKE IF U AGREE

Edited by Onnichan
  • Upvote 9

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...