Jump to content
[DE]Danielle

PS4 Empyrean: Update 27.0.5 (+Hotfixes)

Recommended Posts

22 hours ago, [DE]Danielle said:

BLINK: Blink has been restored and is now a universal ability for all Archwings! We would like to apologize again for the temporary disabling of Blink on Itzal from Rising Tide's launch - but are excited that you'll now have the ability available to use on all Archwings! The new Blink mechanic propels over 2x the distance of original Blink (but can't be increased by Mods), with a cooldown of 3 seconds to prevent spamming - but at no Energy cost to you! 

  • Blink on ALL Archwings: Tap L1 (default)
    • Blink now shares the same button as "Move Down" (L1 by default). Players should find that the new binding has automatically replaced their previous "Move Down" binding! This button is now used to "Move Down / Dodge / Blink", here's how each works:
      • "Move Down": Hold down L1
      • "Blink": Tap L1 to Blink on all Archwings (if it isn't already on cool down)
      • "Dodge":  Tap L1 while moving laterally

Anyone else having trouble using Blink?  I try the "tap L1" but only moves down.  I have tried it on three different Archwings.

 

Edited by (PS4)Ultimaknight

Share this post


Link to post
Share on other sites

Greetings

I've a question about the latest hotfixes for PC. I know there's SOME things you can hotfix on console, and curious if any of the latest will be possible? I completely understand if not, but some of the drop balancing is a big deal, so wanted to ask @[DE]Danielle

I noticed a little bug; I had to reset to default for my Railjack controls to work. It's not much, but in case others have some missing keybinds/features, resetting might solve it.

 

Share this post


Link to post
Share on other sites
hace 1 hora, (PS4)Ultimaknight dijo:

Anyone else having trouble using Blink?  I try the "tap L1" but only moves down.  I have tried it on three different Archwings.

 

try that: change in the options settings, in the conroller section Railjack, change the L1 to R3 and R3 to L1, save, then go to settings again and restore the controls to default, and now its working (for me)

Share this post


Link to post
Share on other sites

I experienced a bug where I had No HUD Including the fighters, and no way to check on the status of the exterminate mission and then the enemies stopped spawning but the mission didn't complete so I had to Restart Warframe and forfeit all the good stuff I got

Share this post


Link to post
Share on other sites
58 minutes ago, (PS4)SgtRavage said:

Is quellor and pennant pick up shared for the whole team now ???

No and I doubt it can be hotfixed in before the year is out. 😕

The universal loot pickup for PC for the Quellor and Pennant bp is in their 0.6 build (ours is only up to 0.5 plus minor hotfixes).

Our version is still buggy as hek...

Share this post


Link to post
Share on other sites

Guys, Blink works, but it is linked to "Down", in my configuration, the "X". Check your mappings, and tap the button for down. It is working for me.

I have flight "UP" in L1, and flight "DOWN" in X, and by tapping X Blink is activated.

But there is a problem that still has not been fixed. Now, the afterburners only are activated in Archwing mode when you push forward the left stick, and this is correct and it is fine; but please, make the same for Razorwing... I am bored of smashing the walls with Titania when I have toggled the Run mode, I am running and use the Razorwing ability. Activating Razorwing, when you are running, will launch you, at top speed, forward, and this is a problem in tight environments, that is just where we use more Razorwing.

Dear DE: How the afterburners are working for Archwings is perfect now... but take into account that having this for Razorwing is even more important that for Archwings. The high speed flight (equivalent to afterburners) should be active only when we push the left stick forward when in Razorwing mode. Thank you.

Happy and quick flights

Of course: Thank you DE !!!, I am enjoying Empyrean greatly.

Share this post


Link to post
Share on other sites

@[DE]Danielle thanks to you and the team for the updates, and keeping us informed.

Any news of a fix for the PS4 frame rate issues yet? They're still at bay and can cause certain games to grind to an almost flick book animation rate of FPS 😞 (as much as it was funny watching a Grineer make his way towards me using 6 animations, it does kinds ruin the game).

 

Also, as others have said, can we have the old Archwing controls back for Titanias Razorwing please? (or at least an option for them?). The new controls don't fit that mode so well, especially the perms-boost if you're not in aiming mode. 

 

Other than that, keep up the good work, and have a great Christmas all! 

Share this post


Link to post
Share on other sites
20 hours ago, (PS4)Ultimaknight said:

Anyone else having trouble using Blink?  I try the "tap L1" but only moves down.  I have tried it on three different Archwings.

 

This seems to be affecting players who have never customized or manually defaulted their controls (this would include brand new players or players who have never ventured into the Customize Controller screen). 

But fear not! We have a workaround for this: All you need to do is go into your "Customize Controller" screen in your Options and "save" on the way out - you do not need to make any changes to your bindings! Simply save and exit.

  • Like 1

Share this post


Link to post
Share on other sites
47 minutes ago, [DE]Danielle said:

This seems to be affecting players who have never customized or manually defaulted their controls (this would include brand new players or players who have never ventured into the Customize Controller screen). 

But fear not! We have a workaround for this: All you need to do is go into your "Customize Controller" screen in your Options and "save" on the way out - you do not need to make any changes to your bindings! Simply save and exit.

Thank you deeply! Was waiting for this.

Share this post


Link to post
Share on other sites

@[DE]Danielle hey so uh, I just installed the update and noticed my kuva ayanga now only has 33 rounds in space like the atmosphere, rather than the 99 mag it's supposed to have... any tips on how to fix this please? It feels nerfed 😕

Share this post


Link to post
Share on other sites
On 2019-12-20 at 11:50 AM, [DE]Danielle said:

This seems to be affecting players who have never customized or manually defaulted their controls (this would include brand new players or players who have never ventured into the Customize Controller screen).

This was indeed my problem. I just return to default the controller scheme without changing anything and it worked perfectly. 

Share this post


Link to post
Share on other sites
On 2019-12-18 at 6:09 PM, (PS4)GUDGER666 said:

The 2 things that were giving me trouble haven't been fixed... There is something wrong with the sensitivity when aiming, my character moves without pressing anything, very annoying especially when trying to synthesise. Many people complaining about this. 

You know its funny because I thought I was going batty the last few weeks.  I would play other games with no issues, but Warframe my controller's camera keeps doing weird things on its own, particularly annoying when mining or something.  I don't even know how to explain it, but it's like the dead zones are way to finnicky now.  I have an issue where if I just barely push left or right, the camera moves in the opposite direction - if i press just a litttttle harder it goes in the proper direction.  It makes fine aiming impossible. 

There's also some cases where I'm not touching the stick itself, but the camera jerks around a bit.  This is a new controller and again, no issues in other games, so its curious. 

Edited by (PS4)Zuzu_with_a_Z

Share this post


Link to post
Share on other sites
On 2019-12-20 at 10:50 AM, [DE]Danielle said:

This seems to be affecting players who have never customized or manually defaulted their controls (this would include brand new players or players who have never ventured into the Customize Controller screen). 

But fear not! We have a workaround for this: All you need to do is go into your "Customize Controller" screen in your Options and "save" on the way out - you do not need to make any changes to your bindings! Simply save and exit.

Thanks!  I can Blink now!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...