Jump to content
General Bug Report Guidelines - Please Read ×

Update 29.10.0: Bug Hunting Megathread (Read First Post!)


Message added by [DE]Danielle,

Please note: All known and fixed bugs, popular and live feedback, and more are being tracked on our Trello board: https://trello.com/b/K34ACrAu

We will not be updating this forum thread with the above. 


Recommended Posts

Type: In-Game, UI/Mechanics, mission-breaking

The tactical menu allows using the railjack quick-teleport nodes even if you're not on the railjack, while you're observing a crewmate. It probably shouldn't let you, this breaks missions.

Reproduction (3/3 for me):

Start early venus proxima missions (this probably works on all, but those were the fastest to test on). Take out security nodes. Board objective ship. Observe that railjack healthbar turns grey (it is now invisible and invulnerable). Observe that using Omni to teleport back is disabled. Press L for tactical menu. Observe that the map shows your current minimap. Press tab. Observe that the crewmates have abandoned their posts and are randomly wandering the railjack (probably part of the same "railjack phases out while solo player is on the objective" mechanic). Observe that the minimap now shows the railjack with quick-teleport nodes. Observe that using "teleport to squadmate" is disabled. Click one of the quick-teleport nodes. Warframe is instantly teleported onto the railjack. Typically the mission fails seconds later (due to objective getting unloaded?) though I had one case (after killing the target number of enemies on RJ exterminate, but prior to exiting the target properly) where it left me in the mission in a weird state, with railjack invisible, guns inaccessible, but the nav console allowing me to navigate back to dry dock.

Image: 5wWzEXf.jpg

Edited to add: Still a problem in 29.10.2 despite patchnotes claiming "Fixed not being teleported into the Capital Ship when using Tactical Teleport via Tactical Map." - Using tactical teleport pulls me out of the capital ship into the railjack, the mission fails shortly afterwards.

Edited by BearPerson
Better image embed, clarify that 29.10.2 did not fix this.
  • Like 1
Link to comment
Share on other sites

  • TYPE: In-game
  • DESCRIPTION: Infinite loading warp from railjack after selecting a mission. Unable to select another mission in the panel because it's inactive. Unable to abort mission from the menu. Had to Alt+F4. Probably lost all mission rewards (no mission endscreen appeared)


  • REPRODUCTION: Try to run a mission after another mission in RJ. After the loading hangs in the warp (already a bug), try to exit the mission from the menu
  • EXPECTED RESULT: The previous mission would show the rewards and the next mission would load properly. If by chance it fails to load, allow to exit from the menu
  • OBSERVED RESULT: 1-Mission wouldn't load. 2-Unable to leave the mission from the menu. Have to Alt+F4 to exit
  • REPRODUCTION RATE: Happened once today. Probably would happen everytime the missions fails to load during the RJ warp
Link to comment
Share on other sites

Type: arsenal, maybe?

Description: I was finishing up the cosmetics and armament for my crew when I went over to the contracts screen and, when I selected my Perrin operative, saw a Bo sticking out of him

Visual: nBT4xKv.png

Replication: unknown at this time, steps to achieve listed above

Expected result: stuck in faction pose

Observed result: s t a f f

Reproduction rate: unknown


Got time for this one? Hopefully you also have time to disable Telos Boltace and Tigris Prime in Conclave! We also have a slew of other bugs, as listed here:

There's even a new one with this update!

  • Like 1
Link to comment
Share on other sites

  • TYPE: Ingame
  • DESCRIPTION: I failed a Volatile mission and was kicked back to my Dojo. There was a few seconds of dead air and a still frame of my spawn room, but I didn't think anything of it. I immediately paused and swapped over to Titania Prime so I could do some build testing, and when I came back to the spawn room some of my trees were blindingly bright, like the lights had been offset.
  • VISUAL: https://imgur.com/a/456YYVW
  • REPRODUCTION: I think I'd also entered a mission and then left it in the flight-loading screen-void bit somewhere in between failing the mission and swapping to Titania. Oh, and if it helps, I was using Zephyr Prime with the new Deluxe skin before Titania.
  • EXPECTED RESULT: I'd assume the lights wouldn't be going nuclear :'D
  • OBSERVED RESULT: The lights are all offset weirdly, making my spawn room blindingly bright.
  • REPRODUCTION RATE: I haven't tried to reproduce it, but it seems like an oddly specific bug.
Link to comment
Share on other sites

6 minutes ago, Funkzie said:

bug : was unable to hit the weakpoint ..

  • TYPE : in-game.
  •  Description : doing the objectives normally.
  • visual : below.
  • Reproduction unknown.
  • Expected: reactor weakpoint to be vulnerable to damage.
  • Observed : I was unable to hit the weakpoint, both with RJ weapons and archwing weapons.
  • Reproduction rate: uknown.
  • Warframe0081.jpg

That's not a bug you can only damage it with the Forward Artillery cannon.

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Trying to complete Railjack Questline
  • VISUALhttps://imgur.com/ezoregJ
  • REPRODUCTION: Possibly going to drydock after completing the final research step of Railjack and attempting to Integrate Cephalon Cy into your Railjack and entering the Railjack for the first time.
  • EXPECTED RESULT: Expected to be able to proceed with questline.
  • OBSERVED RESULT: Getting stuck on a "Please Wait" loading screen.
  • REPRODUCTION RATE: Every time I tried to proceed with the quest line both in the Dojo Drydock and a Relay Drydock, in a public lobby or private I got this result.
Link to comment
Share on other sites

Railjack mission voting broken. Some people can't vote, voting NO does nothing, cancelling vote and voting drydock breaks everything (stuck in pre-warp animation, no menu available, can't leave squad, can fly around and shoot things though, Alt-F4 required, complete loss of mission rewards)

Host can't leave squad.

Did you guys even playtest this nonsense?!?!?!

  • Like 2
Link to comment
Share on other sites

Bug in the other Venus Proxima mission.

We were able to finish the first venus mission, after 1 hour. Then the host decided to go to the next venus mission, but due to lag and insage amount of bugs in this particular mission, I had problems with Omni Tool, random teleports when using /unstuck after dying from 1 attack in venus (I dont  know how).


Firstly, before entering the saboge zone, I had many problem on Railjack becuase suddenly, my warframe decide to exit and use archwing mode, then in enters and immeadiately in exits again....then It freezes at the same time a hull breach appear.....


Then, when those bugs that happend for about 2 minutes, It become normal again, for a while. When we were on sabotage zone, I activated the console, and suddenly, I died. I used X to revive, and I appeared on the Other zone, where you can get new mods from orokin towers.


As my host weren't able to understand the new type of mission, and I don't know either if there is a console to vent the reactor, as bugs doesn't allow me to play, I couldn't explain him anything, and we had lost everythin from both missions (except reactor T1 (like nothing for me) and one mod from orokin towers)


Maybe I should have used omni tool to teleport to railjack and the tactical menu to teleport to my squadmate, but I'm not used to It yet, as It is the first time to have a timer in Railjack and I have never used before.


Indeed, almost 2 hours lost. The bugs we already had the first time Railjack appeared (December 2019) came again. I can't understand that the same bugs are again here. At least, allow us again to use "Navigation" console on mission if we find bugs that doesn't allow us to continue, as we were able to do on Velo Proxima after sentient mission the first time.



Link to comment
Share on other sites

  • TYPE: In-game [Player harassment]
  • DESCRIPTION: Possible Player harassment to the pilot. Players can deploy the Necramech on top of the RJ pilot, completely blocking his view.


  • REPRODUCTION: Summon a Necramech on top of the pilot seat.
  • EXPECTED RESULT: 1- The necramech would spawn some meters behind the pilot so they wouldn't have the camera blocked, or / 2 - "Invalid Spawn Location" message appears to whoever is trying to summon it there, or / 3 - The necramech (and possibly other summonables) would be invisible to the pilot within a radius.
  • OBSERVED RESULT: Nechramech is deployed in a way it can completely block the pilot's view
  • REPRODUCTION RATE: 100%, as long as a player has the "summon nechramech in any RJ Mission" unlocked and wishes to harass the pilot (even the pilot can do this to himself like I did in the picture while solo for testing)
  • Like 1
Link to comment
Share on other sites

TYPE: In-Game

DESCRIPTION: Using Lavos' Second Ability. Before this update, Lavos could cancel his 2 almost immediately. After the update, he now has to wait to cancel it for some time. It sounded like the steering tech was added from Gauss, who appears to have the same distance requirement, but is less noticeable since Gauss is much faster.

VISUAL: I am spamming 2 in an attempt to cancel the ability in this video:




REPRODUCTION: Press 2 on Lavos. Spam the ability button to cancel.

EXPECTED RESULT: The ability should cancel almost instantly. Lavos should take about a step forward before cancelling.

OBSERVED RESULT: Lavos does a full dash until an arbitrary point where you are once again allowed to cancel the ability.

REPRODUCTION RATE: This happens every time when using his 2.

Edited by Valoroy
Link to comment
Share on other sites

  • TYPE: Railjack Clan Research UI, minor edge case UI bug
  • DESCRIPTION: After starting research on a Mk II or III item, it shows the prerequisite block with "Not Researched"
  • VISUAL: yvT3Pd0.jpeg
  • REPRODUCTION: Research Mk I, then start Mk II, and without leaving the console, mouse over the item
  • EXPECTED RESULT: No prerequisite block
  • OBSERVED RESULT: Prerequisite block, and incorrectly showing the previous Mk I / II as "Not Researched".
  • REPRODUCTION RATE: It only seems to happen if you stay at the terminal after starting the research, it fixes itself if you leave and come back.
Link to comment
Share on other sites

  • TYPE: In-Game - Infinitely stacking turret damage
  • DESCRIPTION: As i was configuring my Plexus setup, i suddenly noticed that my turret damage was much higher than it realistically should be. After doing some testing, i found out the reason was that Onslaught Matrix & Protective Shots repeatedly applied their effects when updating the Upgrades UI
  • REPRODUCTION: Simply swap around mods or switch to and from the Upgrades section of the UI with Onslaught Matrix (either currently or when you enter the session) and/or Protective Shots equipped while in an instance that allows you to configure your Railjack.
  • EXPECTED RESULT: The effects still apply and show in the Arsenal, but without repeatedly stacking.
  • OBSERVED RESULT: An additional copy of Onslaught Matrix/Protective Shots is applied every time the Upgrade UI is updated, including copies from your crew; The accumulated turret damage bonus works in Railjack missions, but resets upon fully refreshing the instance. (most commonly through returning to Orbiter)
  • REPRODUCTION RATE: 100% Reproduction rate, provided the criteria mentioned above is met is met.
Edited by Rascus4ever
Added visual example of extreme damage stacking, bug is still present as of Hotfix 29.10.3 despite being stated otherwise: Fixed Onslaught Matrix stacking when you repeatedly equip it in the Plexus.
Link to comment
Share on other sites

  1. While solo, started Falling Glory mission node.
  2. Completed Point of Interest.
  3. Boarded Corpus ship after taking out 2 crewships and 2 ship guns.
  4. Completed 5 waves of defense.
  5. After completion of 5th wave ask to continue defense or end.
  6. Chose end and then received mission failure notice and was back on my Railjack.
Link to comment
Share on other sites

TYPE: In Game

DESCRIPTION: Extracting on a defense node automatically fails the mission and kicks you to your orbiter with no rewards. Ive had this happen both in Venus and in Pluto nodes. Also when i loaded into the mission some of my team mates completely disappeared, eventually fixed itself when they went out and came back into the railjack.



REPRODUCTION: Extract at the venus or pluto defense mission.

EXPECTED RESULT: Shouldve been sent back to railjack and got my rewards.

OBSERVED RESULT: Extracting defense mission kicks me back to orbiter and fails it with no rewards.

REPRODUCTION RATE: Only had one defense mission work until now but then i got stuck in a loading screen and couldnt enter the loot dungeon.


  • Like 1
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: After blinking in Archwing I am just flying with normal speed even tho I am still holding the sprint key. Have to release and press the key again. Was not like this before the update.
  • VISUAL: -
  • REPRODUCTION: Blink in Archwing and try to sprint right after, not gonna work.
  • EXPECTED RESULT: Archwing should keep sprinting after blink and not fly with normal speed.
  • OBSERVED RESULT: Archwing doesn't keep sprinting after blink.
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Camera Inverts
  • VISUAL: https://gyazo.com/05413e04e118348856a2e0b19f24fd3d
  • REPRODUCTION: I dont know what caused it
  • EXPECTED RESULT: Camera clamping how it used to
  • OBSERVED RESULT: Camera clamping roughly 30 degrees to far down so as to invert the character
  • REPRODUCTION RATE: All 3 of us in the mission Calabash got the same bug
Edited by Wooshie42
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Intrinsics are not stacking after each mission in Railjack. They are being overwritten.
  • REPRODUCTION: Just do a mission
  • EXPECTED RESULT: They should keep stacking after each mission.
  • OBSERVED RESULT: When starting a new mission, they are being reset to zero....or being overwritten at the end of a mission.


Edited by PsychoticHeaven
Link to comment
Share on other sites

  • TYPE: [In-Game]
  • DESCRIPTION: [A message from Cy says that things have been returned to my inventory but nothing like that appears in my inventory]
  • VISUAL: [https://imgur.com/w93zrd8][https://i.imgur.com/nWxfokX]
  • EXPECTED RESULT: [I should have the things that appear in the message Cy]
  • OBSERVED RESULT: [I don't have any of that or at least the mods]
  • ADDITIONAL: [I think I got all the things except the mods or the endo]
Link to comment
Share on other sites

  • TYPE: Mission Loading
  • DESCRIPTION: Loading into mission / selecting different node
  • VISUAL: https://gyazo.com/2a17739d509d77fbb406d7cbcd701287
  • REPRODUCTION: Either load into a mission node with a friend (must be on Friends Only).
  • EXPECTED RESULT: Should have loaded into mission.
  • OBSERVED RESULT: Loading screen kept going on for eternity.
  • REPRODUCTION RATE: It only happens when you load into a mission.
Link to comment
Share on other sites

TYPE: In-Game
DESCRIPTION: Can't drift right while piloting railjack with keyboard
REPRODUCTION: Load into railjack and start flying around.  If you hold "a" to drift left it works as expected but holding "d" does nothing.
EXPECTED RESULT: Upon holding "d" the railjack should have started to drift right.
OBSERVED RESULT: Nothing happened at all when holding "d", holding "a" to drift left worked as expected.  Keyboard worked as expected while on foot; only affected the controls while being in the pilot chair.
REPRODUCTION RATE: [Happened in every mission I tried it in.

Link to comment
Share on other sites

The flow from Railjack to on-foot segments can be improved.  Namely, it currently requires the full squad present to start on-foot segments -- it shouldn't.  Squad should be able to join in, but it shouldn't require everyone to start.  That way some can do the on-foot segment while others do the Railjack segment in tandem.

  • Like 1
Link to comment
Share on other sites

TYPE: Ingame

DESCRIPTION: Firing an empty Catabolyst doesn't cause it to reload


REPRODUCTION: I only tried it with the Catabolyst so far, but just empty your magazine ammo bladder and then left click when empty.

EXPECTED RESULT: Left-clicking should trigger a reload (or in the Catabolyst's case, a reload and grenade throw)

OBSERVED RESULT: The gun clicks but doesn't reload

REPRODUCTION RATE: 100% when attempting to use the Catabolyst

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...